Support » Plugin: GigPress » Bug? Incorrect Date? What?

  • I get this error when plugin is enabled and I add one event, and then try to create a new page or post this shows and you can not save any new page or post after the first gig is saved.

    WordPress database error: [Incorrect DATE value: ”]
    SELECT * FROM wp_gigpress_artists AS a, wp_gigpress_venues as v, wp_gigpress_shows AS s LEFT JOIN wp_gigpress_tours AS t ON s.show_tour_id = t.tour_id WHERE show_related = 5356 AND show_expire != ” AND show_status != ‘deleted’ AND s.show_artist_id = a.artist_id AND s.show_venue_id = v.venue_id ORDER BY show_date asc,show_expire asc,show_time asc

    PS. Enable your github “Issues” page guys!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support jeremy80

    (@jeremy80)

    Hi Angel!

    Thanks for reaching out đŸ™‚

    First of all, could you make sure you have the latest version of the plugin (2.3.24)?

    Also, have you already tested for conflicts? If not, could you deactivate all your plugins except for GigPress? Do you still have the same issue this way? You may also try with the default theme (Twenty Twenty for instance).

    Let us know how it goes đŸ™‚

    Thanks, have a nice day!

    Cheers,
    Jeremy

    Thread Starter Angel Hess

    (@akissz)

    Sorry Jeremy. I am a bug creator, I mean I put software through the fire and test a lot of things. I found this bug and I wanted to tell you about it. I don’t have more info. I already deleted everything, including your plugin. 6 week delay on reply is not good for users. Visually the plugin looks good. I can’t remember if I disliked anything else. But it seems like a good plugin, maybe just needs a little fixes here and there.

    traffas

    (@traffas)

    I’ve successfully been able to fix this bug by changing line 29 of output/gigpress_related.php to be

    $date_condition = "IS NOT NULL";

    I have to fix it with each release, but it beats getting this error all the time.

    Plugin Author AndrĂ¡s Guseo

    (@aguseo)

    Hi @traffas and @akissz

    Indeed, that is the issue. I have submitted a fix for that, I’m not sure though when it will be merged into the code and released.

    In the future if you want to you can also contribute to the code via submitting pull request to the GigPress repository.

    We’ll let you know here when this fix is released.

    Cheers,
    Andras

    Intref: GTRIA-534

    Plugin Author AndrĂ¡s Guseo

    (@aguseo)

    @traffas

    An update will come soon that will fix this. We’ll let you know.

    Cheers,
    Andras

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Bug? Incorrect Date? What?’ is closed to new replies.