Support » Plugin: Subscribe to Comments » Bug in v2.3

  • If I am not wrong,
    the code line 168
    add_filter( 'comment_form_defaults', array( $this, 'add_checkbox_to_default' ));
    triggers the add_checkbox function that defines the checkbox_shown attribute to true.

    Then, if you are using the comment_form function with a parameter comment_notes_after different from default, the “Notify me” checkbox is no more displayed.

    I have commented that line 168 !

    https://wordpress.org/plugins/subscribe-to-comments/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thanks Iznogood1.
    I already commented line 168 and plugin is working back again.

    I was surprised it disappeared!

    Instead of editing the plugin file you can add a priority to the comment_form_defaults filter in your theme so it fires before this filter line in the plugin. For example:

    add_filter( 'comment_form_defaults', 'my_theme_comment_form_args', 5 );

    Adding the comma 5 there fires adds the theme filter before the plugin filter and then the checkbox reappears.

    Hi,
    and how would i know what to put in this part?: ‘my_theme_comment_form_args’

    Thanks,

    Commenting out line 168 seemed to do the trick for me. Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Bug in v2.3’ is closed to new replies.