Support » Theme: EasyMag » Bug in theme translation

  • Resolved mohamed.belhassen

    (@mohamedbelhassen)


    Hello,

    I translated the theme frontend to french/Arabic.
    Although that I translated the following strings:

    #: inc/template-tags.php:52
    msgid "Posted in %1$s"
    msgstr "نشر في  %1$s"
    
    #: inc/template-tags.php:33
    msgctxt "post author"
    msgid "by %s"
    msgstr "بواسطة  %s"
    
    #: inc/template-tags.php:28
    msgctxt "post date"
    msgid "Posted on %s"
    msgstr "نشر في %s"
    

    the corresponding text stills shown in english

    Could you assist me to resolve the problem.

    Note that, I uploaded the corresponding translations to the translated repository of the theme.
    In addition, Other parts of the theme texts are translated as expected.

    Cordially,
    M.B

Viewing 3 replies - 1 through 3 (of 3 total)
  • robertolokoloko

    (@robertolokoloko)

    Translating Using Poedit

    1. Install Poedit.

    2. Open Poedit and go to File > New catalog from POT file and select the POT in your theme’s languages folder.

    3. A catalog properties box will pop up asking for information about what you are translating. Enter the language you want to translate here.

    Poedit catalog
    Enter the language you want to translate along with any other important details and hit “OK.”
    4. After you hit “OK,” you’ll be asked what you want to name your translation file. The name is important and there’s a particular format you will need to follow. For example, if you’re translating swedish for sweden, the file should be name sv_SE.po, and for a swedish would be sv_SE.po

    Setting Up Your Translated Theme in WordPress

    As English is the default language for WordPress, you will need to play with a little code to force WordPress to use your translated files.

    In order to do this, you will need to FTP into your WordPress install and open up the wp_config file and add this line of code:

    define (‘WPLANG’, ‘sv_SE’);

    This line specifies the english, so you’ll need to replace en_GB with your language and country code.

    Thread Starter mohamed.belhassen

    (@mohamedbelhassen)

    Dear robertolokoloko,

    I already used poedit.
    It is not the first time where I perform a multi-lingual website.

    you can check the online version of the website on:
    http://club-jsg.org/ar/2016/10/23/clubs/

    please use one of the following urls:
    http://club-jsg.org/ar/

    and not the root url:
    http://club-jsg.org/

    all texts are translated excepts the mentioned ones and some others

    Cordially,
    M.B

    Thread Starter mohamed.belhassen

    (@mohamedbelhassen)

    problem resolved,
    the cause was the name of translation files.
    unfortunately the support team of this theme is not responsive
    I am talking to myself like a crazy in this forum

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Bug in theme translation’ is closed to new replies.