Support » Plugin: The Events Calendar » Bug in plugin Settings

  • Resolved ant123


    When I go to the settings of the plugin, I see the following error message in WP admin (please note that I’m testing the plugin in a subdomain).

    few arguments in /home/customer/www/ on line 110

    Warning: Cannot modify header information – headers already sent by (output started at /home/customer/www/ in /home/customer/www/ on line 9

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Same here when we click on the Settings link:

    Une erreur de type E_ERROR a été causée dans la ligne 110 du fichier /var/www/vhosts/***.com/httpdocs/wp-content/plugins/the-events-calendar/src/admin-views/tribe-options-display.php. Message d’erreur : Uncaught ValueError: Unknown format specifier ” ” in /var/www/vhosts/***.com/httpdocs/wp-content/plugins/the-events-calendar/src/admin-views/tribe-options-display.php:110

    • This reply was modified 4 months, 3 weeks ago by lambrechtj.
    Plugin Author András Guseo


    Hi @ant123 @lambrechtj

    This error can happen for several reasons, some of them not coming from our plugin.

    As a first I would kindly like to ask you to deactivate all plugins and switch to a default theme like twentytwenty and check if you are still getting the error then.

    If not, then it is either the theme you use or one of the plugins causing a conflict.

    Activate the theme first and check to make sure it’s not that one.
    Then start re-activating the plugins a few at a time and keep checking when the error message appears.

    This way you should be able to narrow it down to the plugin that is causing this.

    If you are getting the error with only The Events Calendar active and having a default theme active, then happy to dig further.

    Which version of TEC do you have?
    Which theme are you using?

    @lambrechtj do you also have your site in a subdomain?


    Hello, rolling back to the old PHP 7 did the job. Please let us know when you are PHP 8 compatible.

    Thread Starter ant123


    Hi András,

    Thanks for the answer.

    This is what I tried:

    – Changed the theme to TwentyTwentyOne
    – Deactivated all extensions
    The problem remained.

    To test if it was related to the subdomain, I tried on one of my other WP sites that is not in a subdomain and the same bug came up.

    So, indeed, it looks related to The Events Calendar plugin and, as lambrechtj seems to say, it may come from the compatibility with PHP 8.

    By the way, both lambrechtj and me seem to be using WP in French, but I doubt this can have any influence.

    • This reply was modified 4 months, 3 weeks ago by ant123.
    • This reply was modified 4 months, 3 weeks ago by ant123.

    Same problem here:

    I use french language, and PHP8.0.1, with Avada template

    • This reply was modified 4 months, 2 weeks ago by xoco.

    Hello @aguseo
    I am having some problem like the other guys when I try to switch from one language to another this magic happens :
    Warning: preg_match(): Unknown modifier ‘t’ in /wp-content/plugins/the-events-calendar/src/Tribe/JSON_LD/Event.php on line 178
    I am using the pro version of Translatepress 1.9.6
    and the famous event calendar Version
    and please please Help I am out of solutions I tried to inject mo files and PO files
    and nothing happened, So please be my savior at this bug.
    I am also facing another bug but let’s focus on this first :/

    Plugin Author András Guseo



    If you are not using PHP 8 than your issue is different. In this case please open a new thread so we can keep the communication focused. Thanks for your understanding!

    @xoco @ant123 @lambrechtj

    Indeed, this seems to be language related. This didn’t happen when I used the site in English (UK), English (US) or German.

    So I dug into this and found the issue.
    There is a “glitch” in the French translation. Here’s a screenshot:

    The percentage mark needs to be translated as its HTML entity, so instead of having 100% in the translation you should have 100%.

    I did this and the error was gone.

    Why is this happening?
    Strings that need translation can use placeholders like %s for string, %d for digit and some more. In general the % sign is used in this.
    In the translation the % was used and I guess PHP 8 is looking for the proper placeholder but cannot find it, so throws an error. This is why % needs to be properly translated with its % HTML entity.

    Try and let me know if this fixes it.


    Thread Starter ant123


    Did you fix it directly in the plugin or do we have to do it on our side?
    I just deactivated the plugin, deleted it and reinstalled the latest version and the problem remains.

    Plugin Author András Guseo


    For now the fastest was is to fix it for yourselves. The fastest would probably be with the Loco Translate plugin.

    The translations for the plugins in the repository are submitted by the community and need to be approved by a Global Translation Editor for that language.

    I have submitted a request for this change in the French translations, however our team does not have GTE access for this language, so we need to wait until one of the French GTEs approves it.

    Hope this helps.


    Plugin Support Marho


    Hi there,

    This thread has been pretty quiet for a while, so we’re going to go ahead and close it. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Have a great day.

    Kind regards,


    Plugin Author András Guseo


    Hi @ant123 @hamzaouni119 @xoco @lambrechtj

    Just wanted to let you know that the right translation has been approved and should be already part of the download, or you can download the French translation manually from here, rename it to the-events-calendar-fr_FR.po and .mo, and upload it to the right folder.

    Should you have any further glitches please open a new thread as this one is closed as resolved and is not being monitored further.

    Thanks and cheers,

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.