Support » Plugin: Page Builder by SiteOrigin » Bug in Page Builder

  • When I add word “set” without quotes (even if it is only substring from “kaset”) in Title of any widget (tested in SiteOrigin Editor, WP Text, WP Visual editor and SiteOrigin Features) and click done something stops working.

    I get error:
    POST http://www.mydomain.com/wp-admin/admin-ajax.php?action=so_panels_import_layout&_panelsnonce=36e61d86af 404 (Not Found)

    And it breks at:
    load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,quicktags,jquery-ui-core,jquery-ui-wid…:5

    https://wordpress.org/plugins/siteorigin-panels/

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Greg Priday

    (@gpriday)

    Hi kupili

    Do you get this issue when using the word set in widgets that are outside Page Builder? Like in a normal sidebar. It’s possible that another plugin is hooking into the widgets_title filter and causing problems.

    The solution here might be to disable all plugins besides Page Builder and see if you still get the issue. If it solves the problem, then you can reenable your plugins one by one until the issue comes back. This will help you figure out which one is causing the problem.

    Hello,

    When I use text widget in footer of my theme (or in sidebar) and set title to set everything works (tried with native text widget). When I try to do the same with text widget in Page Builder the thing goes wrong. I disabled all plugins besides Page Builder. Only difference is that I don’t get the error right away trough ajax (when I click done) but when I click Publish page/post I get:

    HTTP/1.1 404 Not Found
    Date: Fri, 04 Sep 2015 21:28:13 GMT
    Server: Apache
    X-Powered-By: PHP/5.4.5
    X-Pingback: http://www.mydomain.com/xmlrpc.php
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Cache-Control: no-cache, must-revalidate, max-age=0
    Pragma: no-cache
    Keep-Alive: timeout=5, max=100
    Connection: Keep-Alive
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=UTF-8

    .

    Plugin Author Andrew Misplon

    (@misplon)

    Hi @kupili

    Sorry to hear about the hassle. Have you made in progress in resolving? Let us know if you still need a hand.-

    Hi,

    I updated the plugin and tried again. I still have the same problem. I am sorry to say that I was unable to debug it myself. In Chrome console I get:

    Failed to load resource: the server responded with a status of 404 (Not Found) http://www.mydomain.com/wp-admin/post.php

    Under network tab when clicking done (when editing widget):

    curl ‘http://www.mydomain.com/wp-admin/admin-ajax.php?_panelsnonce=86b6f765db’ -H ‘Pragma: no-cache’ -H ‘Origin: http://www.mydomain.com’ -H ‘Accept-Encoding: gzip, deflate’ -H ‘Accept-Language: sl,en-US;q=0.8,en;q=0.6’ -H ‘User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.85 Safari/537.36’ -H ‘Content-Type: application/x-www-form-urlencoded; charset=UTF-8’ -H ‘Accept: */*’ -H ‘Cache-Control: no-cache’ -H ‘X-Requested-With: XMLHttpRequest’ -H ‘Cookie: wordpress_54f40ec50741ae83ca526a241bffe148=administrator%7C1442187086%7CYfEAC2ThfdfkqaFnouCgnMf0sQPiXUjcVMwyfeSrCKQ%7Cb1a4e980f61e261bd2ed0f6e45207173ae4a627f5ee912f11c454926606d3235; wp-saving-post=220-check; wordpress_logged_in_54f40ec50741ae83ca526a241bffe148=administrator%7C1442187086%7CYfEAC2ThfdfkqaFnouCgnMf0sQPiXUjcVMwyfeSrCKQ%7Cbbb6fe4ae43a99f9fccb286a0161333b0000ec45f640edc8667248d72d053206; wp-settings-1=widgets_access%3Don%26editor%3Dhtml%26post_dfw%3Doff%26libraryContent%3Dbrowse%26siteorigin_settings_tab%3D3%26siteorigin_panels_setting_tab%3Dlayout%26posts_list_mode%3Dexcerpt%26mfold%3Do%26hidetb%3D0; wp-settings-time-1=1441988288’ -H ‘Connection: keep-alive’ -H ‘Referer: http://www.mydomain.com/wp-admin/post.php?post=220&action=edit’ –data ‘action=so_panels_builder_content&panels_data=%7B%22widgets%22%3A%5B%7B%22title%22%3A%22set%22%2C%22text%22%3A%22%3Cp%3Eneki%3C%2Fp%3E%22%2C%22autop%22%3A%22on%22%2C%22panels_info%22%3A%7B%22class%22%3A%22SiteOrigin_Widget_Editor_Widget%22%2C%22raw%22%3Atrue%2C%22grid%22%3A0%2C%22cell%22%3A0%2C%22id%22%3A0%2C%22style%22%3A%7B%22class%22%3A%22%22%2C%22widget_css%22%3A%22%22%2C%22padding%22%3A%22%22%2C%22background%22%3A%22%22%2C%22background_image_attachment%22%3A%220%22%2C%22background_display%22%3A%22tile%22%2C%22border_color%22%3A%22%22%2C%22font_color%22%3A%22%22%7D%7D%7D%5D%2C%22grids%22%3A%5B%7B%22cells%22%3A1%2C%22style%22%3A%5B%5D%7D%5D%2C%22grid_cells%22%3A%5B%7B%22grid%22%3A0%2C%22weight%22%3A1%7D%5D%7D&post_id=220’ –compressed

    And when I try to publish:

    curl “http://www.mydomain.com/wp-admin/post.php” -H “Pragma: no-cache” -H “Origin: http://www.mydomain.com” -H “Accept-Encoding: gzip, deflate” -H “Accept-Language: sl,en-US;q=0.8,en;q=0.6” -H “Upgrade-Insecure-Requests: 1” -H “User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.85 Safari/537.36” -H “Content-Type: application/x-www-form-urlencoded” -H “Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8” -H “Cache-Control: no-cache” -H “Referer: http://www.mydomain.com/wp-admin/post.php?post=220&action=edit” -H “Cookie: wordpress_54f40ec50741ae83ca526a241bffe148=administrator”%”7C1442187086″%”7CYfEAC2ThfdfkqaFnouCgnMf0sQPiXUjcVMwyfeSrCKQ”%”7Cb1a4e980f61e261bd2ed0f6e45207173ae4a627f5ee912f11c454926606d3235; wp-saving-post=220-check; wordpress_logged_in_54f40ec50741ae83ca526a241bffe148=administrator”%”7C1442187086″%”7CYfEAC2ThfdfkqaFnouCgnMf0sQPiXUjcVMwyfeSrCKQ”%”7Cbbb6fe4ae43a99f9fccb286a0161333b0000ec45f640edc8667248d72d053206; wp-settings-1=widgets_access”%”3Don”%”26editor”%”3Dhtml”%”26post_dfw”%”3Doff”%”26libraryContent”%”3Dbrowse”%”26siteorigin_settings_tab”%”3D3″%”26siteorigin_panels_setting_tab”%”3Dlayout”%”26posts_list_mode”%”3Dexcerpt”%”26mfold”%”3Do”%”26hidetb”%”3D0; wp-settings-time-1=1441988288” -H “Connection: keep-alive” –data “_wpnonce=fd62abd56b&_wp_http_referer=”%”2Fwp-admin”%”2Fpost.php”%”3Fpost”%”3D220″%”26action”%”3Dedit&user_ID=1&action=editpost&originalaction=editpost&post_author=1&post_type=page&original_post_status=publish&referredby=http”%”3A”%”2F”%”2Fwww.mydomain.com”%”2Ftest”%”2F&_wp_original_http_referer=http”%”3A”%”2F”%”2Fwww.mydomain.com”%”2Ftest”%”2F&post_ID=220&meta-box-order-nonce=a943ff42bd&closedpostboxesnonce=de377e8e2c&post_title=set&samplepermalinknonce=f98cf91c7f&content=”%”3Ch3+class”%”3D”%”22widget-title”%”22+style”%”3D”%”22text-align”%”3Acenter”%”22″%”3Etest+se”%”3C”%”2Fh3″%”3E”%”0D”%”0A”%”0D”%”0A”%”09″%”3Cp”%”3Eneki”%”3C”%”2Fp”%”3E”%”0D”%”0A&_sopanels_nonce=2a98f8a44e&_wp_http_referer=”%”2Fwp-admin”%”2Fpost.php”%”3Fpost”%”3D220″%”26action”%”3Dedit&panels_data=”%”7B”%”22widgets”%”22″%”3A”%”5B”%”7B”%”22title”%”22″%”3A”%”22set”%”22″%”2C”%”22text”%”22″%”3A”%”22″%”3Cp”%”3Eneki”%”3C”%”2Fp”%”3E”%”22″%”2C”%”22autop”%”22″%”3A”%”22on”%”22″%”2C”%”22panels_info”%”22″%”3A”%”7B”%”22class”%”22″%”3A”%”22SiteOrigin_Widget_Editor_Widget”%”22″%”2C”%”22raw”%”22″%”3Atrue”%”2C”%”22grid”%”22″%”3A0″%”2C”%”22cell”%”22″%”3A0″%”2C”%”22id”%”22″%”3A0″%”2C”%”22style”%”22″%”3A”%”7B”%”22class”%”22″%”3A”%”22″%”22″%”2C”%”22widget_css”%”22″%”3A”%”22″%”22″%”2C”%”22padding”%”22″%”3A”%”22″%”22″%”2C”%”22background”%”22″%”3A”%”22″%”22″%”2C”%”22background_image_attachment”%”22″%”3A”%”220″%”22″%”2C”%”22background_display”%”22″%”3A”%”22tile”%”22″%”2C”%”22border_color”%”22″%”3A”%”22″%”22″%”2C”%”22font_color”%”22″%”3A”%”22″%”22″%”7D”%”7D”%”7D”%”5D”%”2C”%”22grids”%”22″%”3A”%”5B”%”7B”%”22cells”%”22″%”3A1″%”2C”%”22style”%”22″%”3A”%”5B”%”5D”%”7D”%”5D”%”2C”%”22grid_cells”%”22″%”3A”%”5B”%”7B”%”22grid”%”22″%”3A0″%”2C”%”22weight”%”22″%”3A1″%”7D”%”5D”%”7D&post_layout_noncename=719a44fbaf&_wp_http_referer=”%”2Fwp-admin”%”2Fpost.php”%”3Fpost”%”3D220″%”26action”%”3Dedit&layout_field=&wp-preview=&hidden_post_status=publish&post_status=publish&hidden_post_password=&hidden_post_visibility=public&visibility=public&post_password=&mm=09&jj=11&aa=2015&hh=18&mn=17&ss=37&hidden_mm=09&cur_mm=09&hidden_jj=11&cur_jj=11&hidden_aa=2015&cur_aa=2015&hidden_hh=18&cur_hh=18&hidden_mn=17&cur_mn=26&original_publish=Update&save=Update&parent_id=&page_template=default&menu_order=0&post_slider_noncename=719a44fbaf&_wp_http_referer=”%”2Fwp-admin”%”2Fpost.php”%”3Fpost”%”3D220″%”26action”%”3Dedit&tc_post_id=220&post_slider_check_field=0&excerpt=&meta”%”5B651″%”5D”%”5Bkey”%”5D=layout_key&_ajax_nonce=6aeadef3d5&meta”%”5B651″%”5D”%”5Bvalue”%”5D=&meta”%”5B652″%”5D”%”5Bkey”%”5D=post_slider_check_key&_ajax_nonce=6aeadef3d5&meta”%”5B652″%”5D”%”5Bvalue”%”5D=0&metakeyselect=”%”23NONE”%”23&metakeyinput=&metavalue=&_ajax_nonce-add-meta=b7fd6103e1&advanced_view=1&add_comment_nonce=d659c2c6d6&_ajax_fetch_list_nonce=e290bb5837&_wp_http_referer=”%”2Fwp-admin”%”2Fpost.php”%”3Fpost”%”3D220″%”26action”%”3Dedit&post_name=test&post_author_override=1” –compressed

    Then I see page 404 loaded.

    Plugin Author Andrew Misplon

    (@misplon)

    Thanks for the detailed feedback. Both @gpriday and I are unfortunately unsure as to what the issue is. To try resolve from here our recommendation would be to run through a standard troubleshooting process:

    1. Dashboard > Updates. If there are any pending updates, run them.
    2. De-activate in one go all of your plugins besides Page Builder.
    3. Switch over to Twenty Fourteen or Twenty Fifteen theme.

    You now have a default WP install. If the issue is resolved at this point you can start slowly adding back each of the above items, one by one, and re-testing at each point.

    Let us know how this goes.

    I have activated Twenty Fifteen theme and disabled all plugins besides Page Builder. I still have the same problem. I am running PHP version 5.4.5

    Plugin Author Andrew Misplon

    (@misplon)

    Thanks for the update.

    Super challenging problem. Given the setup you’ve described there shouldn’t be any issues presenting. At this stage I can’t think of any further options other than re-installing WordPress and seeing if that helps.

    Hello,
    I made new install on temp page: test.video-jpl.com
    I still have problem if I use Page builder on a page/post.
    Every title string ending with set breaks publishing.

    If you want you can log in and try.
    User: admin
    Pass: password

    Plugin Author Andrew Misplon

    (@misplon)

    Thanks. There is a login form before the WordPress login. Is the username/password the same?

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    @kupili, Instead of putting a password and username on your page and sharing those credentials, please make your page public.

    Hey,
    I don’t mind because it is only test page (installation of WP), created only for that purpose.
    @misplon: For popup form just read user/pass from the text.

    Plugin Author Andrew Misplon

    (@misplon)

    @anevins, it’s just the admin area that was protected. Site front end is open.

    @kupili, sorry for missing that, taking a look now.

    Plugin Author Andrew Misplon

    (@misplon)

    Amazing bug. Looking a bit deeper now.

    Plugin Author Andrew Misplon

    (@misplon)

    Confirmed. Unfortunately, at this stage we don’t know why this is happening. I can’t re-create locally so that’s a big hurdle. I’m going to log this as a bug for our developers to look at when they have a moment. Assuming we’re both working with the same WordPress core, WordPress settings, Page Builder, Page Builder settings etc. then the only differentiator left is the hosting environment.

    I, unfortunately, don’t have any suggestions for what to do from here. If you had access to another server that would be a nice test to run.

    Sorry, wish I had more right now.

    I could only install on AMP and run locally, but that doesn’t help. As for now I will create title by hand (code).
    I look forward to hearing from you when you manage to resolve this bug or have any other suggestion.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Bug in Page Builder’ is closed to new replies.