Support » Plugin: User Role Editor » bug in multisite when trying to edit user

  • Hi,
    i have install your plugin to test with my wordpress multisite and found some service bug.

    after the setup i have network active the plugin and checked “Allow non super administrators to create, edit, and delete users”

    then i go to some subsite(as site admin) and add new user. new email was sent with activation link.

    i have clicked on the link, and new user shows in user list.

    then i try to edit the user. just put name and clicked “save”
    then i get message “you don’t have permission to edit this user”.
    then i go back to users page and this user disappeared from the user list.

    what can be the problem? can you fix this?

    Thanks

    https://wordpress.org/plugins/user-role-editor/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Vladimir Garagulia

    (@shinephp)

    Hi,

    Only super-admin has permission to edit users under WP multi-site. “Allow non super administrators to create, edit, and delete users” option just remove this limitation, but it does not give to the user any real permissions/capabilities.

    In order to edit user profile under multi-site role or user should have these capabilities: read, list_users, edit_users, add_users, create_users, delete_users.

    In order to edit user you need to select it from the users list under selected site.

    Hi Vladimir Garagulya,
    and how i can give this permission to all sites admin in my multisite?
    i want every site admin be able to edit the user profile for all users that belong to his blog.

    Thanks

    Plugin Author Vladimir Garagulia

    (@shinephp)

    I thought you wrote about usual user, not admin.
    If single site admin has ‘Administrator’ role, he has needed permissions/capabilities by default.
    Please clarify, what and where do you try to do

    then i try to edit the user. just put name and clicked “save”

    Do you edit some fields at single site user profile and then get the error?

    Hi Vladimir Garagulya,
    Yes site admin is administrator of his website(blog).
    so yes when i have add new user, with the site admin user (administrator) the user appeared in the list of site users, then i try to edit this user (name field) and after i click “save” i get this error and the user disappeared from the users list in this specific site.

    “Do you edit some fields at single site user profile and then get the error?”

    Yes i edit the fields in “single site” (on of the blog in multisite) as the site admin on this blog.

    Plugin Author Vladimir Garagulia

    (@shinephp)

    Thanks.
    I made the same steps at test multisite WordPress installation but could not repeat a described issue.

    Try to deactivate any other plugins, activate built-in WP 2014 theme and repeat user add/edit, in order to understand that no conflicts happens from other sources.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘bug in multisite when trying to edit user’ is closed to new replies.