Support » Plugin: Feed Them Social - Facebook, Instagram, Twitter, YouTube, Pinterest » Bug in code to display pinterest boards

  • Resolved SinOB

    (@sinob)


    I am using the most recent version of the plugin (Version 2.4.1 )
    I am getting the following error when I attempt to use the plugin with pinterest with feed type “board list”.
    “Warning: Invalid argument supplied for foreach() in /public_html/wp-content/plugins/feed-them-social/feeds/pinterest/pinterest-feed.php on line 179” This error is displayed in the sidebar when I attempt to use the shortcode as a widget.

    I have tested using a newly generated shortcode (based on at least one of the recent updates borking existing shortcodes) however this has not resolved the problem. The shortcode is currently as follows:
    [fts_pinterest type=boards_list pinterest_name=sineadobriencom boards_count=6]

    If i change the feed type to something else (such as “Pins from a specific board”) the error goes away.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author slickremix

    (@slickremix)

    If you have clicked the button on the Pinterest Options page of our plugin to get an access token make sure you are also using the Pinterest account name associated with that access token. Is that the case?

    Yes it is the case. As mentioned earlier the plugin is working as expected with pinterest when the feed type is changed to individual pins. It is only exhibiting a problem with the boards feed type. It also was not exhibiting this issue prior to my recent update.

    Plugin Author slickremix

    (@slickremix)

    It appears to be working when we test it on our side.
    http://feedthemsocial.com/test3/

    Can you please give us the following information

    1. An example link to the problem in question.
    2. The report from the System Info page of our plugin. Click here if you are unsure how to do this. https://www.slickremix.com/docs/system-info-page/

    Thanks,
    Justin Labadie

    Hi slickremix

    Typical, it would work when you try it.

    That system-info-page is an absolutely excellent idea. I’ve never seen one of those in a WordPress plugin before.

    Based on it working on your site but not on mine I realsied it would probably be easier for me to debug than for you. The solution that worked for me was; delete the plugin on my end, do some manual database pruning, do a reinstall, finally regenerate the shortcode again. This appears to have resolved the issue for me. Thank you for taking the time to investigate and feedback.

    Kind regards
    Sinead

    Plugin Author slickremix

    (@slickremix)

    Hey @sinob,
    Glad you got it worked out! Yea System info has been a game changer for us helping us. Give us so many clues as to what could be going on 🙂

    If you have a second and wouldn’t mind leaving a review for us, we would be very grateful.
    https://wordpress.org/support/view/plugin-reviews/feed-them-social

    Or if you have a facebook account and want to leave a review for us there, that would be awesome too.
    https://www.facebook.com/SlickRemix/reviews?ref=page_internal

    Be sure to follow us on Twitter for important updates @slickremix or https://twitter.com/slickremix

    Thanks,
    Justin Labadie

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.