WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Bug in Advanced Custom Fields?

[Resolved] Bug in Advanced Custom Fields?

  • Good day,

    Does anyone know the solution to the following problem?

    I have recently set up the Advanced Custom Fields plugin with a custom post template and have been using Gravity Forms to submit post data. Everything seemed to be working fine on a number of posts. However, I went to update a post through the post editor screen and when I clicked on ‘update’ or ‘preview’ I got the following error:

    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /home/uswfeoab/public_html/wp-content/plugins/advanced-custom-fields/core/fields/_functions.php on line 396

    This was repeated 8 times before the following error code:

    Warning: Cannot modify header information – headers already sent by (output started at /home/uswfeoab/public_html/wp-content/plugins/advanced-custom-fields/core/fields/_functions.php:396) in /home/uswfeoab/public_html/wp-includes/pluggable.php on line 876

    I have had a good look at the forums and the ACF website but can’t find any troubleshooting for errors relating to the _functions.php file. For reference the line of code on line 396 is $field = array_merge($defaults, $field);

    Unfortunately this is way beyond my PHP skills. Any suggestions would be greatly appreciated!

Viewing 1 replies (of 1 total)
  • Phew!

    The author of Advanced Custom Fields issued and update to Version 4.1.2 today. This has resolved the problem.

    Panic over!

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] Bug in Advanced Custom Fields?’ is closed to new replies.
Skip to toolbar