Support » Plugin: Contact Form 7 » Bug in 4.8.1

  • After update the form doesn´t work. Nothing happens and redirect doesn´t work after trying to send. CF7: 4.8 works ok, but after update to 4.8.1 it stopped working!

    Using this:
    on_sent_ok: “location = ‘https://secret-url.com/’;”
    on_sent_ok: “document.getElementById(‘asaphide’).style.display = ‘none’;”

    WordPress: 4.8
    Avada theme: 5.1.6
    PHP 7.1.7
    MySQL 5.7.13

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi hasse2016
    Did you try deactivate your Avada Theme and test the form?
    It might be something related to the theme, right?
    Best of luck
    AMP.

    The problem isn´t related to the Avada theme. Everything works great with Avada if I go back to CF 4.8. The only change was that I tried to update CF to 4.8.1, so the problem is specific with CF 4.8.1 – not Avada.

    Hello @hasse2016

    I noticed a bug that I was able to trace back to the 4.8.1 update specifically. All form submissions were being collected successfully by Flamingo right up until I applied the update on 27th July. Then, all of a sudden, form submissions stopped being collected.

    I did a little digging and noticed that the Chrome error console was reporting the following issue after loading a page with a CF7 form:

    Failed to load resource: the server responded with a status of 404 ()
    /wp-json/contact-form-7/v1contact-form-7/v1/contact-forms/<form_id>/refill

    After trying to submit a form, an additional 404 error occurs on the following URL —
    https://domain.com/wp-json/contact-form-7/v1contact-form-7/v1/contact-forms/<form_id>/feedback

    Both these URLs are mangled. They should take the following form (note the ‘/v1/’ where the slash was missing before —
    http://domain.com/wp-json/contact-form-7/v1/contact-forms/<form_id>/feedback

    I managed to trace the issue back to CloudFlare. To fix it I switched off RocketLoader then purged the following file from the cache (under ‘Caching’ –> ‘Purge Individual Files’):
    http://domain.com/wp-content/plugins/contact-form-7/includes/js/scripts.js

    Finally, I also then cleared the site page cache and reloaded the page. Voilà!

    Hope this helps you get to the bottom of the issue 🙂

    I’ve done the above steps (clear cache for both cloudflare & wp super cache) and I still get the same error (don’t have rocket fuel enabled though):
    https://www.domain.com/wp-json/contact-form-7/v1contact-form-7/v1/contact-forms/73041/refill

    • This reply was modified 2 years, 5 months ago by dsecareanu.

    Hi @dsecareanu,

    Have you tried putting CloudFlare into development mode and disabling Super Cache caching? Do you have another plugin running that concatenates scripts such as Autoptimise? If so, temporarily switch that off too.

    Also, just to be precise — I’m not sure whether you mistook CF Rocket Loader with something else?

    Let me know how you get on,
    Ian

    Hi,
    I don´t use Cloudflare or Rocketloader. I switched off WP Rocket and all other plugins, no difference.
    Please not that the issue started with the last version, no problems before with all the plugins, WP Rocket etc activated.

    Hi @hasse2016,
    The steps outlined in my post were the precise steps I took to be able to resolve the problem. If you don’t use CloudFlare then you probably have something else at play here that is causing the issue.

    It’s an obvious thing to check, but so we can rule it out, have you visited your site in incognito/private browsing mode? The old CF7 scripts.js might still be in your browser cache.
    Hope this helps,
    Ian

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Bug in 4.8.1’ is closed to new replies.