[resolved] [closed] Bug in 3.2.1, admin drop down menus disabled agaaaaain (36 posts)

  1. SuzanneL
    Posted 4 years ago #

    Hello, this happened a few versions back in the 3 series, and was corrected with a subsequent update. It seems that this bug has been re-introduced -- the drop downs on the right side of admin are disabled. Once in a while I can get the left menu column to open up, and the OZH overhead menu bar is ok, but the drop downs in the right side of admin are 100% disabled. This means no editing widgets, no adding media to a post, no selecting Screen Options. I maintain a lot of WordPress sites, over 10, spread over several different hosting services, so I know it's not the hosting services, and I know it's not me, because it's happening on every one I've updated so far, and on different browsers - Firefox, Chrome, Opera.

    I'm running Windows XP on a netbook. I can get wp dropdowns to work on MSIE 8, but it scolds me for using an "out of date" browser, but I don't want to upgrade that if that's the last place wp dropdowns work! I don't use MSIE unless I have to. I can possibly run Linux via live CD w/ Firefox on it, but I have not tested if that works with wp drop downs.

    I would really just like WordPress admin drop downs to just go back to working with the next wp upgrade. Just find where the bug was re-introduced, and re-remove it.


  2. You're going to hate me.

    It's probably you.

    I say that because this is the first time I'm hearing of this, and 3.2.1 has been out for a while.

    So have you done the normal debugging? Turn off plugins, etc. I use XP and Chrome/Safari/FireFox and drop downs work just fine.

  3. and the OZH overhead menu bar is ok,

    if you're adding that plugin to all sites it could be interfering.

  4. SuzanneL
    Posted 4 years ago #

    Nah, I only have it on a few sites, because I don't want to confuse people on the sites where the admin is shared. OZH had its own problem with the new wp upgrade -- it was leaving a blank left column behind. Deactivating and entirely deleting OZH, then reinstalling with completely fresh OZH code solved that problem :-)

    For the moment I'm stumbling along with IE8, but I'd like to not have to do that.

  5. Interesting. Given that you had to delete Ozh's plugin, I wonder if your database is hanging onto anything it shouldn't be...

    How do you feel about spinning up a TEST install of WP in a subfolder on your server?

  6. SuzanneL
    Posted 4 years ago #

    Here is proof that the problem is not me -

    I have installed two fresh test installs of WP:

    1. test01, WP 3.1, installed via cpanel Fantastico, which does not display the buggy problems I am describing. No problem with clicking on anything on the right side of the admin backend, no problem flipping back and forth between Visual/HTML editing of a new post.
    2. test02, WP 3.2.1, manual install (3.2.1 being so brand spakin' new :-P, it has not yet propagated to Fantastico), which is every bit as buggy as I described.

    Please write me for the usernames & passwords, as you can understand I don't really want to post them on a public forum.

  7. That doesn't prove it's not you, y'know.... I can install 3.2.1 on my server without any issues. That doesn't mean it's NOT WP, just that it works for me and not for you. Does that make sense?


    Are you using a brand new database for these tests?

  8. SuzanneL
    Posted 4 years ago #

    Yes, I've just installed two pristine WordPress installations side by side, at your request. Brand new database for each, no plugins, no nothin'. One is version 3.1, the other is version 3.2.1

    3.1 admin side works 100% fine.

    3.2.1 admin side disables clicking on most everything on the right hand side of the admin side. You cannot even log yourself out.

    So no, it is not me. Even if the requirements for client software have been changed, that needs to be documented, and that alone would be WP's fault.

    If you work for WordPress.org, or have any interest in solving this bug, you may request the usernames and passwords. Either contact me directly, or post a way for me to contact you and send them.

    Thank you for your attention to this problem.

  9. esmi
    Forum Moderator
    Posted 4 years ago #

    So no, it is not me

    Sorry but yes, it is. It's specific to your site or your server. Tens (hundreds?) of thousands of people have upgraded from 3.1 to 3.2.1 without these problems. Ergo - it's not a WordPress issue but a site/server one.

    If you work for WordPress.org

    No one here works for wordpress.org. This is a volunteer staffed forum.

  10. fonglh
    Posted 4 years ago #

    Did you download a fresh copy of 3.2.1 when you installed the 2nd test site?

    It might be your download that got corrupted.

  11. SuzanneL
    Posted 4 years ago #

    You just proved that the problem is WordPress.

    I use a large host service, one of the largest.

    3.1 works.

    3.2.1 does not work.

    No difference between them, other than that.

    Therefore, if WP has changed either the server requirements, or the client software requirements, please point me to the documentation so I can fix it. Lack of documentation of new requirements would make it WP's fault, not the server's fault.

    Because I am the first to report the problem only makes me the first. It does not make me wrong. If you have no interest in solving this particular problem, then why are you responding? Many thanks to those who are interested.

    No need to request a password to see this problem. You can create your own (defaults to Editor role):

    WP Version 3.1 Test01

    WP Version 3.2.1 Test02

    Thank you very much for experimenting with this and seeing what I mean.

  12. SuzanneL
    Posted 4 years ago #

    PS, Yes, Fonglh, I did download and install a fresh copy of 3.2.1 for the pristine 3.2.1 installation. The problem presents itself whether I download fresh code, upgrade from older code, or "Reinstall" completely over an upgrade.

    Thx again.

  13. fonglh
    Posted 4 years ago #

    I just created an account on your test02 site. No problems with adding media to a post or playing with the screen options. The Editor role doesn't have the rights to play with widgets so I couldn't test it out.

    I could also add new categories, change the publish date, move the boxes on the right side of the admin around, and expand/collapse them.

    Browser is Google Chrome.

    Are you using the latest versions of the various browsers you've tried?

  14. SuzanneL
    Posted 4 years ago #

    Thank you, fonglh. That tells me the server is serving the site correctly :-)

    Yes, I have upgraded my Chrome, Opera, and Firefox to all top of the line most recent versions, and I have had no luck. In fact, when you said you got it working on your Chrome, I presumed the problem must be my operating system, Windows XP. (What OS are you running?)

    So I jumped on my son's computer, a desktop tower running Windows Vista, but I had the exact same results as I've been having on my XP Acer netbook. I even upgraded his Chrome and Opera (his Firefox was already running the most recent version). The results were exactly the same:

    • WP 3.1 works fine, but WP 3.2.1 will not activate anything on the right hand side of the admin side. No widget dragging, no adding media to a post, no screen options, not even logging oneself out.

    My son's Vista computer is running MSIE9, and yes, WP 3.2.1 will work on MSIE9 (as well as the MSIE8 on my netbook). But not a single browser of any other stripe will run WP 3.2.1 on either of our computers.

    So I then decided to tested both my netbook and his tower booted to Ubuntu 10.10 Live USB. That just gives us the Firefox that comes with it, and the results were again exactly the same:

    • WP 3.1 works fine, but WP 3.2.1 will not activate anything on the right hand side of the admin side. No widget dragging, no adding media to a post, no screen options, not even logging oneself out.

    So I called a friend who is running Linux/Ubunto 11, with its incarnation of Firefox - and the WP 3.2.1 works just fine for him.

    So for jollies, I pulled my other son's other tower out of the closet, dusted it off, and tried that. I don't know what operating system it used to be. I suspect it was XP, but it was in the closet for a reason and it will not boot to Windows anymore. So I booted that to the Linux/Ubuntu 10.10 Live USB - with the exact same results as above - WP 3.1 thumbs up, WP 3.2.1 thumbs down.

    So I am happy for the people WP 3.2.1 works for. I have, however, identified 3 computers and 3 operating systems, for which WP 3.1 works fine, but WP 3.2.1 does not not - XP/Vista/ & Linux/Ubuntu 10.10

    Unless of course the Windows computers concede to run MSIE.

    Perhaps I should re-title this forum thread "Snookered by Microsoft".

    It is time for this elusive problem to get a bug ticket number

    Anyone who wants to play with this and see for themselves can create accounts for themselves on the side by side sites:

    Test01 WP 3.1, which defaults to Editor mode, but allows you to make posts and set "Screen Options", so you don't upgrade the WP on each other, and

    Test02 WP 3.2.1, which defaults to Administrator mode, so you can succeed or fail at dragging widgets, making posts with images in them, and flipping the "Screen Options" on or off.

    If you do try it out, lease post your results, along with which OSes & browsers you used.


  15. jruimages
    Posted 4 years ago #

    Just found this post. I'm having the same issues. I didn't notice immediately because we run a photo blog and only post once or twice a month. At first I assumed it was a user error on the part of our blog manager. I jumped through all the usual hoops (browser upgrades, etc) and still haven't resolved it. I'm pretty sure this is a WP problem. I'm a little surprised. For as widely-used as WP is, you'd think they'd be on top of these issues with a little more alacrity. I manage several aspects of our online presence and this is the sort of thing you'd expect from a platform developed and managed part-time by a college student.

    Seriously. Could you please fix this right away? I just wasted three hours on this. I won't tell you what I bill out at but you owe us some bucks. My takeaway: Put "Check forums" at the top of my problem solving procedure, not the bottom.

  16. jruimages
    Posted 4 years ago #

    It's not just Microsoft, Suzanne. I'm having the same problem on my Windows machines as well as on our Macs, both OSX Snow Leopard and Lion.

  17. NikLir
    Posted 4 years ago #

    I have upgraded to wordpress 3.2.1 too. The menu down the left hand side which has my posts medial links pages comments appearance plugins users tools settings and so on is gone. I cannot navigate through my site properly to make changes and some things I can not change at all as there is no way to navigate without the menu.

    I am new to wordpress and have limited knowledgs so need someones help in a step by step explanation on what to do and where to go to do it.

    I use windows 7, safari browser, Hostgator for hosting, i do not want to upgrade too of my other sites (blogs) for fear of the same thing happening.

    My site bestchilblainstreatment.com is my very old grandmothers home made product and this is her only way of making a little extra money to get by. I made this site for her and am worried I can not make necessary changes arghhhhh. HELP

  18. jruimages
    Posted 4 years ago #

    spent some time online with our HostGator techs. They run PHP 5.2 by default. not sure if 5.2.4 has critical modifications that WP 3.2.1 needs. trying to get them to upgrade us to 5.3...

  19. fonglh
    Posted 4 years ago #

    I did the test on Windows Vista. Can try a few other operating systems later.

    Based on what you have said, it seems like the problem only occurs on your machines. Could you take a netbook out and try it out on another network? Maybe at a public WiFi hotspot.

    @jruimages, no one owes you any money. If you need assistance or troubleshooting ideas, please start your own thread and try the troubleshooting master list in the troubleshooting forum.

    By the way, many of the WordPress contributors are indeed doing it voluntarily and on a part time basis, including the people answering questions in these support forums. I'm sure there are some college students too.

    Welcome to open source :)

  20. jruimages
    Posted 4 years ago #

    dude, fonglh. I'm no open source noob. don't be so condescending. I am fairly new to WP and didn't realize it was an open source project. that does explain a lot.

    you're actually wrong about people owing me money. I know several people who owe me money but of course my comment was just a way of venting my frustration at having to switch gears from real work to problem solve something that worked just fine a month ago and doesn't work now after an upgrade. But thanks for your comment.

    To all you volunteers and college students: some of us, many of us, maybe most of us who use this software, are not doing it as an intellectual exercise or because we're supervising the computer lab and we're bored. We're doing it because it's part of our jobs. We don't need cutesiness or snarkiness. Speaking for myself, that just makes me want to hack your kernels and screw with your version dependencies.

    the problem is a server side problem and I've already resolved it, fonglh dude. thanks anyway. btw, I had tried all your suggestions before I came on here looking for other ideas. so in hindsight maybe I will keep "check forums" at the bottom of my problem-solving grid for WordPress...

    jruimages out.

  21. fonglh
    Posted 4 years ago #

    No one HERE owes you any money. It was in response to your statement "you owe us some bucks". My statement was meant to be read in context. Taking it out of context and calling it wrong doesn't make sense at all. I appreciate your need to vent your frustations, but criticizing people who provide great software for free, and support for free, isn't the best way to get help.

    If you're using WordPress as part of your job, some basic knowledge of web hosting and programming is assumed. You did not state what you have tried or what you already know, so I was only able to give you general advice. As you said, it is YOUR job, so if you need help, please ask nicely. I don't think it's too much for the volunteers here to expect some basic courtesy and politeness instead of a "you owe me support" attitude.

    I'm glad you've resolved your problem. As you've admitted, it wasn't WordPress after all.

  22. fonglh
    Posted 4 years ago #

    Sorry for the distraction SuzanneL. That's why we always tell people to start their own topics.

    Anyway, I've tried your test 3.2.1 site on Ubuntu 11.04 (Firefox) and Windows 7 (IE and Chrome). No problems there.

    I've also tried it on Windows XP, Firefox 3.6.8 and Firefox 5.0.1. I get the outdated browser warning on 3.6.8 but the right side admin menu works. I can switch widgets around, change screen options etc.

    Unfortunately, it looks like no one so far has been able to reproduce your problem, so it won't be treated as a WordPress bug. Your ticket will just be closed as "works for me" or "can't reproduce". I'm not sure what the exact terminology is.

  23. Works for me AND can't reproduce, probably, fonglh :/

    I can run WP on Mac (Snow Lep and Lion), Ubuntu and Windows (XP and 7). So can about 10k people.

    WP 3.1 works fine, but WP 3.2.1 will not activate anything on the right hand side of the admin side. No widget dragging, no adding media to a post, no screen options, not even logging oneself out.

    I'm gonna go on a limb and say it's most likely an issue with how PHP is configured on your server.

  24. kendawes
    Posted 4 years ago #

    Hi Susan,
    I had the similar problem... one install was fine, one would not allow dragging widgets, screen options didn't work, etc.

    Googling around, I saw mention of a jquery problem...

    On a whim I installed Jason Penny's "Use Google Library" plugin ... Viola!

    Problem gone!


  25. kev2329
    Posted 4 years ago #

    Had exactly the same problems as everyone else above on upgrades and clean installs of 3.2.1 so installed the plugin described in the post above and now everything works 100% again. (Big sigh of relief) Thanks kendawes

  26. yvesf
    Posted 4 years ago #

    I had the exact same problem using a late 2008 aluminium MacBook now on MacOSX Lion and using browsers Safari, Chrome and Opera. On all 3 browsers I had the same problem after updating to WP 3.2.1: the dropdown menus did not work.
    After installing and activating the above mentioned plugin (Jason Penny's "Use Google Library"), everything worked again.
    @kendawes - thank you. your post was the most helpful one in this topic (I had to unfortunately read all the ranting and blaming posted before your post before I found the answer)
    @WP forum moderators/developers - a button next to the posts saying "most useful" or a way to rate answers would be quite helpful in finding answers quicker.

  27. watsontcbc
    Posted 4 years ago #

    This IS a WordPress problem. I have two sites so far this has hapened to neither of which I had taken any action on within the timeframe that these menus quit working. One site I simply deleted all the menu items in the WordPress menus section, and allowed the normal page heirarchy to do the job, like in pre 3.x versions. Works fine. For the other, much larger site, I tried the Use Google Libraries, and it did not work. WordPress, you need to fix this problem ASAP. I don't have time for this.

  28. This still falls under 'can't reproduce' and 'works for me' for everyone but a few select cases.

    Now that said, the menus are getting a bit of an overhaul in 3.3, so when that comes out it may fix it for you.

  29. hmbranco
    Posted 4 years ago #

    thanks, kendawes. I've been looking for this in 2 days, it was driving me crazy!!! :) the "use google libraries" plugin does works! :) I'm going to post this in other unresponded threads, in order to help others! :) THANK UUUUU!!! :)

  30. Cythorn Creative
    Posted 4 years ago #

    'Use Google Libraries' fixed it for me too.

Topic Closed

This topic has been closed to new replies.

About this Topic