Support » Plugin: Facebook Open Graph, Google+ and Twitter Card Tags » [BUG] Image assets no longer inserting

  • Resolved flynsarmy

    (@flynsarmy)


    After your update this morning, images no longer insert when clicking ‘Insert Image’ in the ‘Add Media’ modal. I’ve narrowed the cause of this down to the script at the bottom of your wonderm00n_open_graph_add_posts_options_box function:

    echo '<script type="text/javascript">
    	jQuery(document).ready(function() {
    		jQuery(\'#webdados_fb_open_graph_specific_image_button\').click(function(){
    			tb_show(\''.__('Upload/Choose Open Graph Image', 'wd-fb-og').'\',"media-upload.php?type=image&TB_iframe=true&post_id='.$post->ID.'", false);
    		});
    		window.send_to_editor = function(html) {
    			imgurl=jQuery("<div>" + html + "</div>").find(\'img\').attr(\'src\');
    			jQuery("#webdados_fb_open_graph_specific_image").val(imgurl);
    			tb_remove();
    		}
    	});
    	</script>';

    Steps to replicate:

    • Go to Posts – Add New
    • Click ‘Add Media’
    • On the ‘Upload Files’ tab, upload an image
    • Click ‘Insert into Post’

    No image will appear in the editor.
    http://wordpress.org/plugins/wonderm00ns-simple-facebook-open-graph-tags/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author wonderm00n

    (@wonderm00n)

    Version 1.0.1 fixes this. Can you please confirm it sou I can set this ticket as “resolved”?

    Thank you VERY MUCH for the report.

    gcluley

    (@gcluley)

    Thanks for fixing this. I thought I was going mad…

    Plugin Author wonderm00n

    (@wonderm00n)

    Shame on me 🙂

    gcluley:
    Do you confirm it’s fixed and you can now insert images into the editor, the featured image field and my plugin’s new field?

    flynsarmy

    (@flynsarmy)

    Fix confirmed. All good now.

    Plugin Author wonderm00n

    (@wonderm00n)

    Resolved.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[BUG] Image assets no longer inserting’ is closed to new replies.