• This causes the error described in https://wordpress.org/support/topic/uncaught-error-call-to-a-member-function-get-on-null-3/, that is “Uncaught Error: Call to a member function get() on null”. You will probably need to set the language to something other than english.

    The error goes like this, referencing the callstack below:

    #11: wp_cache_init() is called. This will initialize the $wp_object_cache global object.
    #9: An error occurs, causing an exception. This would be something like the Redis server being down or something which stops the plugin from connecting.
    #8: show_error_and_die() is called to notify the user of the problem
    #7: The message __( ‘Error establishing a Redis connection’, ‘redis-cache’ ) is sent to the translation system using __ .
    #1: The translation system calls WP_Textdomain_Registry->get_language_files_from_path() to load the language files needed to translate the message
    #0: This tries to use the cache with wp_cache_get(), which calls ->get() on the $wp_object_cache global. But this has not yet been initialized, so instead of a useful error message, the system crashes with the fatal error “Call to a member function get() on null”

    [26-Apr-2024 07:21:11 UTC] PHP Fatal error:  Uncaught Error: Call to a member function get() on null in /www/wp/wp-content/object-cache.php:193
    Stack trace:
    #0 /www/wp/wp-includes/class-wp-textdomain-registry.php(187): wp_cache_get()
    #1 /www/wp/wp-includes/class-wp-textdomain-registry.php(302): WP_Textdomain_Registry->get_language_files_from_path()
    #2 /www/wp/wp-includes/class-wp-textdomain-registry.php(98): WP_Textdomain_Registry->get_path_from_lang_dir()
    #3 /www/wp/wp-includes/l10n.php(1354): WP_Textdomain_Registry->get()
    #4 /www/wp/wp-includes/l10n.php(1384): _load_textdomain_just_in_time()
    #5 /www/wp/wp-includes/l10n.php(194): get_translations_for_domain()
    #6 /www/wp/wp-includes/l10n.php(306): translate()
    #7 /www/wp/wp-content/object-cache.php(2974): __()
    #8 /www/wp/wp-content/object-cache.php(2940): WP_Object_Cache->show_error_and_die()
    #9 /www/wp/wp-content/object-cache.php(566): WP_Object_Cache->handle_exception()
    #10 /www/wp/wp-content/object-cache.php(256): WP_Object_Cache->__construct()
    #11 /www/wp/wp-includes/load.php(860): wp_cache_init()
    #12 /www/wp/wp-settings.php(144): wp_start_object_cache()
    #13 /www/wp/wp-config.php(66): require_once('...')
    #14 /www/wp/wp-load.php(50): require_once('...')
    #15 /www/wp/wp-blog-header.php(13): require_once('...')
    #16 /www/wp/index.php(17): require('...')
    #17 {main}
      thrown in /www/wp/wp-content/object-cache.php on line 193
Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    Thanks for the new thread. What is the version number at the top of your wp-content/object-cache.php file?

    Thread Starter Iver Odin Kvello

    (@iverok)

    Version 2.5.2. WordPress 6.5.2, WooCommerce 8.8.2, language set to nb_NO.

    The original error is unknown because it unfortunately, sort of, resolved it self during debugging, but any kind of exception during initialization should reproduce.

    Plugin Author Till Krüss

    (@tillkruess)

    Can you empty your logs fully and then copy the original redis-cache/includes/object-cache.php to wp-content/object-cache.php so we have a fresh setup and see if the error still occurs? If it does please post the entire error log file.

    Thread Starter Iver Odin Kvello

    (@iverok)

    It does in version 2.5.2. I just set up a site with no redis connection and locale set to nb_NO and activated the object-cache by copying it into wp-content. Backtrace and error below.

    The actual error “show_error_and_die()” tries to print is
    Connection refused [tcp://127.0.0.1:6379]

    — but instead it breaks the site with a 500 error because it tries to translate ‘Error establishing a Redis connection’, which tries to use the cache object which isn’t initialized yet. As mentioned, any exception thrown during initialization will cause this.

    [10-May-2024 09:57:12 UTC] PHP Fatal error:  Uncaught Error: Call to a member function get() on null in /wp/wp-content/object-cache.php:193
    Stack trace:
    #0 /wp/wp-includes/class-wp-textdomain-registry.php(187): wp_cache_get()
    #1 /wp/wp-includes/class-wp-textdomain-registry.php(302): WP_Textdomain_Registry->get_language_files_from_path()
    #2 /wp/wp-includes/class-wp-textdomain-registry.php(98): WP_Textdomain_Registry->get_path_from_lang_dir()
    #3 /wp/wp-includes/l10n.php(1370): WP_Textdomain_Registry->get()
    #4 /wp/wp-includes/l10n.php(1400): _load_textdomain_just_in_time()
    #5 /wp/wp-includes/l10n.php(194): get_translations_for_domain()
    #6 /wp/wp-includes/l10n.php(306): translate()
    #7 /wp/wp-content/object-cache.php(2974): __()
    #8 /wp/wp-content/object-cache.php(2940): WP_Object_Cache->show_error_and_die()
    #9 /wp/wp-content/object-cache.php(566): WP_Object_Cache->handle_exception()
    #10 /wp/wp-content/object-cache.php(256): WP_Object_Cache->__construct()
    #11 /wp/wp-includes/load.php(860): wp_cache_init()
    #12 /wp/wp-settings.php(144): wp_start_object_cache()
    #13 /wp/wp-config.php(87): require_once('...')
    #14 /wp/wp-load.php(50): require_once('...')
    #15 /wp/wp-admin/admin.php(34): require_once('...')
    #16 /wp/wp-admin/options-general.php(10): require_once('...')
    #17 {main}
      thrown in /wp/wp-content/object-cache.php on line 193

    Hello,

    I have same problem . In my configuration i have 2 virtual machines in my pc. In the first i have Windows server 2016 where i installed the website in the laragon web server application and in the last i have ubuntu server 22.04 where i have a redis cluster. But laragon has a redis installation and if i activate it the plugin go very well but if i decided to use the redis server i have a problem like the last post.

    The plugin detect the connexion and Phpredis but if i click on activate object cache to enable it i have some kind of errors translation. Or may be we should buy the pro version?

    Thread Starter Iver Odin Kvello

    (@iverok)

    @momozizou the actual error causing your problem is something else than this bug, which is about a failure to translate that original error. You probably are getting a connection error of some sort though, so you may want to check your connection settings.

    Hello @iverok

    I have the same error output. Like i said, the connexion is Ok and it’s writable before i decide to click in the Activate Object Cache button. My database is in antoher ubuntu server where i install mysql-server and it work. I think it’s not the connexion.

    Thanks

    • This reply was modified 1 week, 5 days ago by momozizou.
    Thread Starter Iver Odin Kvello

    (@iverok)

    @momozizou Well, to find out what the error is, you will need to edit your object-cache.php file and inspect the $exception there before the translation functions are called. This issue in particular isn’t about the actual underlying error; just the failure in the error reporting function. In my case, this error was me not starting the redis server on purpose to provoke the translation error, so it is almost certainly not the same in your case.

    There is a method in object-cache.php named “show_error_and_die”, you could edit that, replacing (temporarily!) the body of that method with

    protected function show_error_and_die( Exception $exception ) {
       wp_die("Redis: " . $exception->getMessage());
    }

    That should eliminate the translation lookup issue and hopefully point to what the underlying issue is.

    Hello @iverok

    I replace the code in the function and now i have this Redis: Unable to send command at the specified node.

    I have this in my wp-config.php file

    define( 'WP_REDIS_PREFIX', 'siteone' );
    define( 'WP_REDIS_TIMEOUT', 5 );
    define( 'WP_REDIS_READ_TIMEOUT', 5 );
    
    define( 'WP_REDIS_CLIENT', 'phpredis' ); 
    define( 'WP_REDIS_CLUSTER', [
    'tcp://192.168.43.245:7000', 
    'tcp://192.168.43.245:7001', 
    'tcp://192.168.43.245:7002', 
    
    ] );
    

    click

    (@perwilhelmsen)

    @momozizou – please post your issues on a fresh thread, as this is about something totally different.

    👍

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.