WordPress.org

Forums

[resolved] BUG: Formatting toolbar disappears if page is too long (10 posts)

  1. Mugsy
    Member
    Posted 3 years ago #

    (It took me about a months to finally figure this one out.)

    I have a separate page in my blog that is basically an ordered list of links. The list has grown quite long (over 550 lines).

    Very recently, when I went to update my list, I discovered that the formatting toolbar (b, i, link...) above the textbox had vanished. Disabling all my plugins (about 15) brought it back, but no particular plugin was the one culprit.

    Only by loading other shorter pages did I discover the toolbar was fine and appearing normally.

    Apparently, when a page gets "too long", some obscure buffer overload is preventing the Formatting Toolbar from loading.

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Can you replicate the problem using the Twenty Eleven theme with all plugins deactivated?

  3. Mugsy
    Member
    Posted 3 years ago #

    Esmi,

    No. As I said, deactivating all plugins already "fixes" the problem temporarily. But the problem isn't a particular plugin, it's the amount of MEMORY those plugins use.

    I've tried changing themes. It's not a theme issue.

  4. esmi
    Forum Moderator
    Posted 3 years ago #

  5. Mugsy
    Member
    Posted 3 years ago #

    According to phpinfo, my host has set the memory limit to 90M. That should be WAY more than enough.

  6. Mugsy
    Member
    Posted 3 years ago #

    Follow-up. Noticed another value:

    post_max_size 8M

    First attempt to increase failed. Host PHP changes are set to Disabled.

  7. esmi
    Forum Moderator
    Posted 3 years ago #

    That should be WAY more than enough.

    Not necessarily. It depends how many plugins you are using and what kinds of plugins they are.

  8. Mugsy
    Member
    Posted 3 years ago #

    The mystery grows.

    I located the php.ini file in the wp-admin directory (which is also where the troublesome "post.php" script is) and opened it:

    php_flag
    register_globals off
    register_globals = 0
    memory_limit = 128M

    ...yet according to phpinfo, my memory limit is still only 90M. I also added:

    post_max_size = 16M

    ...for good measure. Checked phpinfo again. Still reads 8M.

    Knowing the settings are "directory specific", I placed copies of php.ini in my root AND plugins folders. No change.

    My host tells me that "php.ini" is the method I should be using to change "PHP Directives", but something appears to be overriding my changes.

    To make matters worse, it appears disabling all of my plugins no longer "fixes" the problem even temporarily (and perhaps never did. I'm not sure of anything anymore).

    The help is greatly appreciated.

  9. esmi
    Forum Moderator
    Posted 3 years ago #

    Checked phpinfo again. Still reads 8M.

    Not all hosts allow you to increase your memory limit or the max upload size via the php.ini file. Have you asked yours if they do?

    Have you tried checking your server's error logs for clues?

  10. Mugsy
    Member
    Posted 3 years ago #

    Checked error logs. Nothing.

    BUT... I found a "fix" by accident.

    As I noted, I've been updating this one page for months (since May 21st) and never had a problem until recently. Other shorter pages didn't have the problem with the missing toolbar, so I assumed the problem was my page had reached a point where it was just too long.

    Curious at what point my post became "too long", I deleted (after pasting a copy to Notepad) the last 50 lines (more than I added in the past few weeks), and nothing changed. So I cut it in half and again nothing changed. Toolbar still gone.

    (scratching head...)

    So I created a new blank page (where the toolbar loaded fine) and pasted the entire list into it. Saved it as a draft, closed and reopened. TOOLBAR LOADED JUST FINE!

    Went back to original page. Still no toolbar. So I deleted my "bad" page and published the working copy. Toolbar is still fine on the new copy.

    I can only assume now it had nothing to do with "length" or "memory". Just too many edits I suppose. But if anyone else encounters a similar problem, just try using a fresh copy. Weird.

Topic Closed

This topic has been closed to new replies.

About this Topic