[bug?] False 'siteurl' upon install behind proxy (6 posts)

  1. svenjick
    Posted 7 years ago #

    I recently had to install a wordpress on a not yet existant url. Created the hosting and use my provider's proxy to prepare the site before changing the registrar's dns entries.

    The install goes fine, the 5 min install ends, and then when I try to log-in, the browser tells me that cookies are not supported and that I should activate this option. Of course, they were already active at the time of log-in. Furthermore, strangely, I had no visible styling, just minimal html rendering.

    I had a look at the db entries, and found a weird entry in table wp_options in the option_name column for the siteurl entry. I had:

    (where "blog" was the name of the folder where I put the files on my hosting)
    I intuitively replaced this by:

    This solved the problem, styled the pages and allowed me to log-in. I had a look the the wp-advanced forum and didn't find anything similar. Since I can't post there, I post here. Hope this helps.

  2. moshu
    Posted 7 years ago #

    There is nothing "advancved" - it's a simple How-To question.
    The two URI values in admin > Options > General MUST point to the real physical location of the blog.

  3. svenjick
    Posted 7 years ago #

    Sorry!!! The tone of your first sentence fills me with guilt - I'm only trying to help.

    Now my point was that "I can't login to the admin" with the std 5-min install procedure under this behind-proxy configuration. So I don't see how I could have reset these URI (which by the way I didn't set in the first place either). Hence my assumption this might be a small 'bug' in the setup-script. Does this make any sense?

  4. moshu
    Posted 7 years ago #

    The two values in wp_options (i.e. site_url and home) must reflect your real install location.
    WP is "reluctant" to collaborate with any kind of tricky redirect attempts or not straightforward installations.
    That's all.

    Install it where you (will) use it - and there are no problems.

  5. svenjick
    Posted 7 years ago #

    As explained, I'm preparing a new version of a site, so I can't change the official dns entry, I must work under this configuration. (this is std practice in the web-dev community, nothing "tricky")

    Now changing the two URL in admin > Options > General didn't solve the problem. So changing manually in the db is necessary to gain access to the admin, but isn't enough to view the blog properly (it is rendered, but all url in the site are wrong). Changing the "Blog address (URL)" in the Options makes things worse, as the blog no longer is visible (error page).

    Definitive workaround:
    You can trick your browser by adding an entry to your /etc/hosts file (for those who don't know how to do that, just add a line containing: www.mysite.com where is the ip of your proxy/hosting) This solves all problems whilst working on a site behind a proxy.

    Misc: I was using Firefox and its manual proxy configuration. No idea where this problem is coming from (FF or proxy conf or wordpress).

    Hope this helps. Peace.

  6. laroca
    Posted 7 years ago #

    I changed the site URL in the admin page. Now I cant get back in to change. How can I fix the problem?

Topic Closed

This topic has been closed to new replies.

About this Topic