Support » Plugin: Clean Login » BUG* Error messages not showing.

  • Resolved Josh Fisher Nesbitt

    (@mrjoshfisher)


    Hello,

    I’m using the awesome plugin and its really working a treat, but I’m having an issue with the error messages as they don’t show when I do something wrong, I can see the updates in the URL but it’s not reflecting on the form.

    I’ve had to do some editing of the plugin in order to get them to show. mainly including the adding $_GET[‘login’] as my URL is as follows when I do something wrong

    ?login=failed&wp-error=<strong>ERROR<%2Fstrong>%3A%20The%20password%20you%20entered%20for%20the%20username%20<strong>josh<%2Fstrong>%20is%20incorrect.%20<a%20href%3D"https%3A%2F%2Fexample.com%2Fwp-login.php%3Faction%3Dlostpassword">Lost%20your%20password%3F<%2Fa>&pr-user-login=xxxx

    Cheers

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Alberto Hornero

    (@hornero)

    Hi @mrjoshfisher thank you very much for reporting this issue and also a possible solution. Would you mind explaining which part of the code you did modify?

    Thanks!

    Thread Starter Josh Fisher Nesbitt

    (@mrjoshfisher)

    Hello,

    Had to alter the clean_login_show function on Line #36

    changed to the following:

    // show login form
    		if ( isset( $_GET['authentication'] ) || isset( $_GET['login'] ) ) {
    			if ( $_GET['authentication'] == 'success' || $_GET['login'] == 'success' ) {
    			
    				echo "<div class='cleanlogin-notification success'><p>". __( 'Successfully logged in!', 'clean-login' ) ."</p></div>";
    			
    			} else if ( $_GET['authentication'] == 'failed' || $_GET['login'] == 'failed'  ) {
    			
    				echo "<div class='cleanlogin-notification error'><p>". __( 'Wrong credentials', 'clean-login' ) ."</p></div>";
    			
    			} else if ( $_GET['authentication'] == 'logout' || $_GET['login'] == 'logout' ) {
    			
    				echo "<div class='cleanlogin-notification success'><p>". __( 'Successfully logged out!', 'clean-login' ) ."</p></div>";
    			
    			}else if ( $_GET['authentication'] == 'failed-activation' || $_GET['login'] == 'failed-activation' ) {
    			
    				echo "<div class='cleanlogin-notification error'><p>". __( 'Something went wrong while activating your user', 'clean-login' ) ."</p></div>";
    			
    			}else if ( $_GET['authentication'] == 'disabled' || $_GET['login'] == 'disabled' ) {
    			
    				echo "<div class='cleanlogin-notification error'><p>". __( 'Your account is currently disabled', 'clean-login' ) ."</p></div>";
    			
    			} else if ( $_GET['authentication'] == 'success-activation' || $_GET['login'] == 'success-activation' ) {
    			
    				echo "<div class='cleanlogin-notification success'><p>". __( 'Successfully activated', 'clean-login' ) ."</p></div>";
    			
    			}
    		}

    Cheers

    Josh

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘BUG* Error messages not showing.’ is closed to new replies.