WordPress.org

Forums

Bug? "Enable Sending Referers" (11 posts)

  1. thudfactor
    Member
    Posted 11 years ago #

    Hello. I'm new to WordPress and new to working with CVS and nightly builds, so if I don't give enough info, please let me know and I'll try to do better next time.
    There seem to be problems with the check_admin_referer script.
    error message does not accurately describe the error.
    ---- I installed from the CVS today (May 18) without too much trouble, but when I tried to activate plugins or change user levels I got the message "Sorry, you need to enable sending referrers, for this feature to work." My referrers *were* enabled, as I saw after echoing the variables tested by check_admin_referer.
    url_shorten routine causes incorrect check_admin_referer failure for some admin urls.
    If the admin url (after having "http://www." chopped off the front) is more than 32 but less than 35 characters, check_admin_referer will incorrectly fail. This is because url_shorten will *not* change the last several characters to "..." in the admin url, but it *will* change those characters to "..." in the referer url. This only happens when the admin url is between 32 and 35 characters (as mine is). Striping "url_shorten" from the check_admin_referer seems to fix this problems, but may have other ramifications with which I am unaware.

  2. Anonymous
    Unregistered
    Posted 11 years ago #

    I have been having the same "enable sending referrers" problem when trying to add/edit/delete links.
    Firefox 0.8, Mozilla 1.6, Safari 1.2.1 (v125.1) as well as IE6/win
    All exhibit the same behaviour. Confirmed that it happens in the plugins and users section as well.
    CVS build downloaded at May 19 @ 06:00am GMT

  3. Matt Mullenweg
    Troublemaker
    Posted 11 years ago #

    Fixed and comitted.

  4. Anonymous
    Unregistered
    Posted 11 years ago #

    RE: Sorry, you need to enable sending referrers, for this feature to work.
    Checked out the latest CVS as of May19@07:30GMT and the problem is still occurring in Links, Users and Plugins.
    Referrers are definitely enabled.

  5. Jinsan
    Member
    Posted 11 years ago #

    um, so does anyone know how to fix this? I just upgraded from 1.0.2 because I wanted the sub categories and other features.
    i was so close to using wordpress, and then installed tikiwiki - both seem great, just hard pushed to choose wordpress with referrer issue.
    Thanks in advance

  6. Beel
    Member
    Posted 11 years ago #

    Matt says it is fixed so it probably is. The fix will show up shortly in the CVS or download the next nightly.

  7. asx
    Member
    Posted 11 years ago #

    Dumb question - do you have any personal firewall software, such as Norton Internet Security, running on the client you are using to administer your site? Some software, as part of their privacy protection features, monitor and filter your outbound connections on port 80, and strips referrer information (among others) on the fly. I ran into this issue as well, until I remembered I had encountered the same problem with the w3.org validator service when using the "referer" method.
    The personal fw software my company was using had privacy protection enabled, which blocked most of the metadata my browser sent, including referers. After I added my host to the ignore/trusted list, everything worked properly.
    Just a thought.

  8. tim1962
    Member
    Posted 11 years ago #

    asx,
    How right you are! Thanks for the response. Problem resolved.
    tb

  9. hdstich
    Member
    Posted 11 years ago #

    hmm,
    I used to connect to my photoblog using SSL (https://DigitalFotoKunst.de/) and that seemed also to generate the 'Sorry, you need to enable sending referrers, for this feature to work.' message!
    switching back to http 'solved' the problem.
    -hd

  10. Tim Griffin
    Member
    Posted 10 years ago #

    I also am running into this problem, running 1.3-pre-alpha.
    I am on a LAN - am able to add posts - but no editing, no enabling plugins, and no deleting.
    I do not have a firewall on this pc.
    Any suggestions?
    Thanks.

  11. rknet
    Member
    Posted 10 years ago #

    I think I figured out something. If I entered my site through http://www.mydomain.com/wp-login.php I get the error. But if I enter through http://www.mydomain.com/wordpress/wp-login.php it seems to be fine. Must have done something screwy when I moved WordPress up a level.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.