Support » Plugin: W3 Total Cache » [BUG] Disk Enhanced cache doesn't work in 0.9.2.4

  • After upgrading to 0.9.2.4 thepage cache with disk enhanced mode stops to work. Also with developer version.

    <!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/
    
    Minified using disk: basic
    
    Served from: x.com @ 2011-09-02 06:21:50 -->
    
    <!-- W3 Total Cache: Page cache debug info:
    Engine:             disk: enhanced
    Cache key:          mozilla-firefox-6-0-1-final-28422.html/_index.html_gzip
    Caching:            enabled
    Status:             not cached
    Creation Time:      0.958s
    Header info:
    X-Pingback:         http://x.com/xmlrpc.php
    Content-Type:       text/html; charset=UTF-8
    Link:               <http://x.com/?p=28422>; rel=shortlink
    Last-Modified:      Fri, 02 Sep 2011 06:21:50 GMT
    Vary:               Accept-Encoding, Cookie
    Expires:            Tue, 06 Sep 2011 10:21:50 GMT
    Pragma:             public
    Cache-Control:      public, must-revalidate, proxy-revalidate
    Etag:               2e497b7dfa045eebf0f3020fcf94c1b7
    X-Powered-By:       W3 Total Cache/0.9.2.5b
    Content-Encoding:   gzip
    -->

    I can see the file “mozilla-firefox-6-0-1-final-28422.html/_index.html” but not the gzipped one “mozilla-firefox-6-0-1-final-28422.html/_index.html_gzip” in my pgcache folder.

    So I have tryed to disable Browser Cache compressione (Enable HTTP (gzip) compression).
    Here is the result:

    <!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/
    
    Minified using disk: basic
    
    Served from: x.com @ 2011-09-02 06:21:50 -->

    As you can see, the debug info about page cache aren’t there. It is like Page Cache is disabled at all.

    The only thing I can do is to enable the Page Cache with Disk Basic mode.

    Try yourself.

    Please, help. I need the Disk Enhanced!!

Viewing 15 replies - 1 through 15 (of 27 total)
  • The same thing happens also in my other 5 blogs, one of them uses the trailing slash in permalink structure, so the error is not due to trailing slash.

    I think this is a serious bug.

    I’ve just tryed on a VMware local test machine and I get the same error: Disc cache enhanced doesn’t work. I always get a “Status: not cached” for every page without any reason.

    Please Frederick Townes, look into this.

    Plugin Author Frederick Townes

    (@fredericktownes)

    Thanks, but nothing to do.
    I tryed on a test server with only W3TC actived, nothing else.
    With or whithout the option “cache requests only for same hostname” gives the same result: status not cached (but without any reason).

    The other option “cache URIs with query string variables” is not activable when I use Disc Enhanced.

    Tryed with various option for permalink structure, but nothing.

    Plugin Author Frederick Townes

    (@fredericktownes)

    Can you please try the development version? Also query strings cannot be cached in disk enhanced due to limitations with web servers, it’s not a W3TC limitation.

    Yeah, I can confirm that the problem isn’t the any-hostname option. I set W3TC when updated to 924 to cache everything, no matter what url the request is.

    I have already tryed thedevelopment version, and my site doesn’t have query string and as I already said, I have tried with various permalink structure, with trailing slash, with .html, without trailing slash…. all the same.
    The page uncompressed is created in cache folder, but the gzipped one no. So no page cached is serverd. And if I unselect the “compress page” option, the disc cache stops to work at all.

    Look at my first post: X-Powered-By: W3 Total Cache/0.9.2.5b

    I have 5 blogs on 3 different servers and I have the same problem. I have tryed also with all plugins disabled, all but W3TC.

    @galerio- FWIW, I’m running 0.9.2.5b on one site and 0.9.2.4 on 2 others (multisite with domain mapping)and I have the following files for every page & post on every site:

    _.index.html and _.index.html_gzip

    But page cache debug still reads “status: not cached”.

    Could you disable the Debug flag?
    It looks like W3TC caches the request you queried, but it serves you the version with the debugging details.

    I’m on w3tc trunk with 3.2.1

    Success!
    I’ve tried on one of my blogs and disabling the debug mode now it writes the plain html file and the gzipped one.

    I’m goning to try on the other servers.

    But, how can I know that the cache is ok if I can’t use debug?

    @stas Suscov-

    Could you disable the Debug flag?

    What do you mean?

    @robnalexpress
    http://i.imgur.com/VX2Bz.png

    @galerio
    Cached pages with no debug generate a message like this:

    View post on imgur.com

    @stas Sucov
    if you are logged in, you’ll neve see cached page untile you disable the option to not serve cached page for admin and logged users.
    Use another browser that you never use to log into your wp

    The second image was taken using Chrome incognito mode.

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[BUG] Disk Enhanced cache doesn't work in 0.9.2.4’ is closed to new replies.