Support » Plugin: Germanized for WooCommerce » Bug: Compatibility to Woocommerce 3.0

  • Resolved iceteabottle

    (@iceteabottle)


    Hi guys,
    there are some compatibility errors with woocommerce 3.0. E.g.
    /includes/class-wc-gzd-checkout.php:226 -> $order->id this is a protected member. In the pro version of the plugin there also issues with the class class_wc_checkout.phpposted() is an deprecated function.

    Hope it will be fixed soon 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author vendidero

    (@vendidero)

    Hi there,

    the /includes/class-wc-gzd-checkout.php:226 piece of code is legacy – it will not be accessed if you are running WooCommerce >= 3.0. We are checking against the version with:

    if ( wc_gzd_get_dependencies()->woocommerce_version_supports_crud() )

    the deprecated function call will be replaced upon next version, see:
    https://github.com/vendidero/woocommerce-germanized/commit/550255d34e012b3c4f33caa79ca66f167f60de5d

    Regarding the professional version:
    Do you have the latest version installed? We are not calling the posted array any longer.

    cheers

    • This reply was modified 2 years, 6 months ago by vendidero.

    Thanks for your fast reply. Sorry it was my fault – there’s another plugin with this mentioned problems. To update the pro plugin was a good idea^^

    Thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Bug: Compatibility to Woocommerce 3.0’ is closed to new replies.