WordPress.org

Forums

Client Status
[resolved] Bug: client-status list nesting (5 posts)

  1. Michael Clark
    Member
    Posted 2 years ago #

    I've got client-status running on 21 sites, all on WP 3.4.2. On the dashboard site, when looking at the Client Status report (under Dashboard > Client Status) somehow the nesting is getting messed up. The first couple sites look just fine, then all of a sudden a couple have no report data at all, then several more are fine. When I click the site name to toggle the details, a few open correctly, and others don't open at all. Any idea what I could check for problems? I see nothing odd in the server logs. I can send you a screen shot or html of the page, but I'd rather not do that on a public page. Mike

    http://wordpress.org/extend/plugins/client-status/

  2. ericjuden
    Member
    Plugin Author

    Posted 2 years ago #

    Michael,

    My guess would be an error in the xml feed being passed back to the dashboard site. Make sure you don't have debugging enabled on your servers.

    Thanks,

    Eric

  3. Michael Clark
    Member
    Posted 2 years ago #

    Nope, good guess though. All the sites are on the same server, same software versions, almost the exact same plugins. What else could I check?

  4. scotthack
    Member
    Posted 2 years ago #

  5. Michael Clark
    Member
    Posted 2 years ago #

    I figured out the problem a few days ago. I apologize for not updating this ticket. The sites that weren't nesting correctly had some rules in the site's .htaccess file that prevented external users from accessing the blog's .php files inside the wp-content directory. I whitelisted the client-status data.php file and it started working.

    So I guess the suggestion would be to have the main client-staus machine fail nicely when it can't contact a client.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Client Status
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.