Support » Plugin: PublishPress Blocks – Advanced Gutenberg Blocks, Permissions, Layouts, Forms » Bug: Cant edit Advanced Image Block caption (v. 2.1.5)

  • Resolved webksde

    (@webksde)


    Version 2.1.5

    Tried it on multiple WP instances (but with very similar plugins, so possibly its a plugin conflict or something..).

    How to reproduce:

    1. Create a page
    2. Add an Advanced Image Block
    3. Edit the text – works fine
    4. Choose an image
    5. Try to edit the caption text again ==> not working anymore, behaves like regular, static text. No JS errors or something in the console.

    So ..the currently the only chance is to add an entire new block so you can edit the text ONCE.

    • This topic was modified 1 year, 3 months ago by webksde.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor JoomUnited

    (@joomunited)

    Hi,

    Thanks for reporting. We recently published version with a lot of changes in the advanced image block. Could you take a look and let me know if you’re still facing the problem.

    Thanks.

    Hi, thank you for the fast response!

    Sadly there’s no difference. Installed the update, cleared the caches and created a new page with a new adv. image block. Also tried in different browsers.

    But i just figured out.. if you click on the text and then press the arrow buttons on your keyboard, the cursor appears 🙂 Maybe a Flexbox problem or something.. not sure.

    Ah, got it.. no Flexbox bug. Theres a pointer-events:none set on .advgb-image-title.

    .editor-styles-wrapper .advgb-image-block .advgb-image-title,
    .editor-styles-wrapper .advgb-image-block .advgb-image-subtitle,
    .editor-styles-wrapper .advgb-image-slider-item-info .advgb-image-title,
    .editor-styles-wrapper .advgb-image-slider-item-info .advgb-image-subtitle {
    pointer-events: none;
    }

    Plugin Contributor JoomUnited

    (@joomunited)

    OK got it, we’ll include a quick fix.

    Cheers,

    Plugin Contributor JoomUnited

    (@joomunited)

    I’ve run some test and did not see the issue, is your procedure to reproduce like that:
    https://drive.google.com/open?id=1kQnifOWZDwPbzbU0kyipkEGquncqvxHR

    Tested in Firefox 70:

    https://drive.google.com/open?id=1o_GOPxbPJoozU6-HKubGTec7-NzSJPeK
    (i am also typing letters while clicking)

    Oum.. cleared all my caches again, new behavoir:

    https://drive.google.com/file/d/1KHWFF_Gu9UHvbN8JTKupK8idv8EZo4H9/view?usp=sharing

    I can click but not type.

    Plugin Contributor JoomUnited

    (@joomunited)

    Hi,

    I’ve made some test with firefox and didn’t have the problem on my side. Can you try with chrome or using a firefox incognito tab?

    Cheers,

    Sorry, but its exactly the same behavoir in Chrome.

    It just works correct (in FF and Chrome) if i remove the pointer-events:none from

    .editor-styles-wrapper .advgb-image-block .advgb-image-title, .editor-styles-wrapper .advgb-image-block .advgb-image-subtitle, .editor-styles-wrapper .advgb-image-slider-item-info .advgb-image-title, .editor-styles-wrapper .advgb-image-slider-item-info .advgb-image-subtitle{ … }

    The Advanced Gutenberg Version is 5.8.6

    • This reply was modified 1 year, 2 months ago by webksde.
Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Bug: Cant edit Advanced Image Block caption (v. 2.1.5)’ is closed to new replies.