Support » Plugin: WP API Menus » Bug and Proposed Fix

Viewing 9 replies - 1 through 9 (of 9 total)
  • Melanie_D

    (@melanie_d)

    I’m able to replicate same issue.. Have you heard of an update?

    bponghneng

    (@bponghneng)

    @melanie_d Pull request submitted for fix. Haven’t heard back.

    Melanie_D

    (@melanie_d)

    ugh. I guess I’ll have to look at your pull to fix for meantime..

    Thanks!

    bponghneng

    (@bponghneng)

    @melanie_d My patch is in the wp-api-v2-menus.php file. The existing method for walking the nav tree inherently causes the error, so I had to rewrite with another strategy. It’s in get_menu_location(). Double-check on the diffs in case I’m forgetting something.

    I’m a WordPress newbie (though not new to PHP), so consider my code suspect 🙂 I thought I might write a new set of menu routes for my own purposes as it takes several GETs on these endpoints to build a usable tree of nav menu items. Let me know if you’d like to collaborate via a fork of this one.

    Melanie_D

    (@melanie_d)

    Thanks.. Will take a look. Definitely would be open to collaborate on a fix. Looks like this bug had happened a few times in this plugin.

    I also received the same bug and it seems your fix works correctly. Thanks for that!

    Plugin Author Fulvio Notarstefano

    (@nekojira)

    hey there, thanks for the PR

    replied to you here https://github.com/unfulvio/wp-api-menus/pull/22

    seems like it’s solving the issue for more users

    any further comment before I merge? (please comment on GH)

    thanks and sorry for the delay

    Plugin Author Fulvio Notarstefano

    (@nekojira)

    I’ve updated the code / merged PRs on the Github repo

    https://github.com/unfulvio/wp-api-menus

    anyone reading this thread could you check it out from the master branch and let me know if issues are solved for all of you?

    thank you

    I’ve updated the plugin from your master branch and it seems to be working for me. Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Bug and Proposed Fix’ is closed to new replies.