Support » Plugin: All in One SEO Pack » Bug: All settings lost every few days

  • The plugin restores all settings to the default settings every 2 or 3 days or so. This is quite annoying because all social meta tags disappear then. I wasn’t able to find a cause. No other plugin on the site has this problem.

    Does anyone else have this problem?

    Where and how does the plugin store its setting. Is this documented?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    This sounds like a likely plugin conflict. Try these troubleshooting steps: https://semperplugins.com/documentation/how-to-troubleshoot-issues-with-all-in-one-seo-pack/

    Thanks for the reply. This procedure does not work in this case because the problem only occurs occasionally. What I need to know is the location where the plugin stores its settings, so I can track down possible conflicts.

    Plugin Author Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    The code is searchable at https://github.com/semperfiwebdesign/all-in-one-seo-pack
    We use standard WordPress functions, like update_option()

    Thanks! I skimmed a little through your code and I doubt that this is a plugin conflict. More likely is that the error occurs under special conditions like when a sever is very busy.

    I wonder why you don’t try to read the options from the database right before you initialize the settings to defaults in aisop_functions.pho. Wouldn’t that be safer? If $aioseop_options gets lost somewhere along the way, you will overwrite existing user settings. I would always double-check before you overwrite user settings.

    I have evidence now that this problem occurs when the traffic is high. During the holidays the plugin worked just fine, but now as we have more traffic the plugins resets everything every 3-5 days or so.

    When I remove line 45 in /inc/aisop_functions.php (aioseop_mrt_mkarry()), no more resets occur.

    I wonder why you call this function while the plugin is running? Shouldn’t you call it only when the plugin is activated or when the user manually resets? If the plugin can’t find the current settings for some reason during normal operation, you should throw a meaningful error message and not just silently reset everything, so admins have a chance to figure out what went wrong.

    Plugin Author Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    I’ve opened an issue to look at improving this here: https://github.com/semperfiwebdesign/all-in-one-seo-pack/issues/1475

    Michael

    (@michael8888)

    Thanks!

    This is bug is still not resolved in version 2.5. Only if I disable aioseop_mrt_mkarry() does All in One SEO Pack keep its settings.

    Plugin Author Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    @michael8888

    Please see if version 2.6 fixes it for you

    Michael, thanks. I just updated. It will take a little until I know if the problem is fixed.

    The plugin bug still exists. It appears to happen less frequently, but this can have other reasons. It might be an incompatibility with the popular W3 Total Cache plugin. But this is only a wild guess.

    Note that we use countless other plugins that store their options in a similar way and All in One SEO Pack is the only one that constantly resets its settings.

    I think you need to completely rewrite the procedure that tests whether the plugin is loaded the fist the time.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.