Support » Fixing WordPress » Bug after updating to wordpress 5.4

  • Gérald Mardirossian

    (@gerald-mardirossian)


    Bug after updating to wordpress 5.4 : I can still edit some of my pages, but when I try to edit some of my pages : I get a white page….really bothersome

    Anyone else has bumped into similar issue after updating ?

    I have siteorigin PageBuilder that I haven’t updated the few last months…but I don”t know if it is the issue here…

    Thanks for your help

Viewing 12 replies - 1 through 12 (of 12 total)
  • Glenn

    (@hometowntrailers)

    I would definately 100% get all your plugins and themes up-to-date as a first step.

    Gérald Mardirossian

    (@gerald-mardirossian)

    OK I did a few updates (…) But it didn’t change the problem.
    So I activated the debug mode to true to this the error message which was not displaying.

    It is weird because I can still edit lots of page but just a few of pages cannot be edited and the page gets white (since I updated to the last wordpress version)

    Here is the error message displaying
    Notice: Undefined index: extended_valid_elements in /wp-content/plugins/protect-schemaorg-markup-in-html-editor/tinymce-schemaorg-markup.php on line 64

    So it is because of this plugin https://fr.wordpress.org/plugins/protect-schemaorg-markup-in-html-editor/

    maybe deactivating it could solve my problem when I have to edit my page and then I should activate it again once I am done )

    Gérald Mardirossian

    (@gerald-mardirossian)

    I tried deactivating only the plugin and then I tried editing the page…the error message is not there anymore…but the page is still all white……….

    I can see this kind of things on the console

    Uncaught TypeError: CodeMirror.fromTextArea is not a function
    at post.php?post=1264&action=edit:1976
    rich-text.min.js:6 Format “core/code” is already registered.
    Q @ rich-text.min.js:6
    rich-text.min.js:6 Format “core/strikethrough” is already registered.
    Uncaught TypeError: CodeMirror.fromTextArea is not a function
    at post.php?post=1264&action=edit:1974
    rich-text.min.js:6 Format “core/code” is already registered.
    Q @ rich-text.min.js:6
    rich-text.min.js:6 Format “core/strikethrough” is already registered.
    Q @ rich-text.min.js:6
    react-dom.min.js:103 Error: Minified React error #130; visit https://reactjs.org/docs/error-decoder.html?invariant=130&args%5B%5D=undefined&args%5B%5D= for the full message or use the non-minified dev environment for full errors and additional helpful warnings.
    at Rc (react-dom.min.js:157)
    at react-dom.min.js:75
    at T (react-dom.min.js:87)
    at re (react-dom.min.js:95)
    at Vg (react-dom.min.js:95)
    at ph (react-dom.min.js:217)
    at lh (react-dom.min.js:126)
    at O (react-dom.min.js:121)
    at ze (react-dom.min.js:118)
    at react-dom.min.js:53
    ve @ react-dom.min.js:103
    react-dom.min.js:157 Uncaught (in promise) Error: Minified React error #130; visit https://reactjs.org/docs/error-decoder.html?invariant=130&args%5B%5D=undefined&args%5B%5D= for the full message or use the non-minified dev environment for full errors and additional helpful warnings.
    at Rc (react-dom.min.js:157)
    at react-dom.min.js:75
    at T (react-dom.min.js:87)
    at re (react-dom.min.js:95)
    at Vg (react-dom.min.js:95)
    at ph (react-dom.min.js:217)
    at lh (react-dom.min.js:126)
    at O (react-dom.min.js:121)
    at ze (react-dom.min.js:118)
    at react-dom.min.js:53

    I should maybe downgrade to the previous wordpress version ? everything was fine…yesterday….

    I downgrade to the last version and the problem it’s fixed. I had the same problem. I use this plugin to downgrade: https://wordpress.org/plugins/wp-downgrade/

    I don’t know if it was coming from the new version 5.4 or if it’s a plugin that causing the trouble.

    Anyway I will wait for the next release of 5.4 and also wait to see if the plugin that I’m using will have some fix to the issues. But it’s weird because on my wordpres I only have the common plugin. Nothing much installed on it to keep it light.

    If you guy’s find out if any plugin have conflict with the new 5.4 or if the 5.4 itself that cause this trouble, let us know!

    Hello,

    did you find the solution I get a white page to on my website here https://www.rolexdhl.com/ can someone help me pleas

    thank you

    @rolexdhl check my post

    I’m also experiencing something that could be the new update. What brought my attention to this thread is the error I’m experiencing on react-dom.min.js:103.

    In each block I’m seeing the text “This block has encountered an error and cannot be previewed.” So I hop into the JavaScript debugger and observe lots of errors that say:

    TypeError: "m.find is not a function"
        n https://example.com/wp-includes/js/dist/block-editor.min.js?ver=704b9a6d689b18b6982a8b2ae902e7ec:50
        Me https://example.com/wp-includes/js/dist/block-editor.min.js?ver=704b9a6d689b18b6982a8b2ae902e7ec:50
        useMemo https://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:205
        useMemo https://example.com/wp-includes/js/dist/vendor/react.min.js?ver=16.9.0:32
        Me https://example.com/wp-includes/js/dist/block-editor.min.js?ver=704b9a6d689b18b6982a8b2ae902e7ec:50
        Oe https://example.com/wp-includes/js/dist/block-library.min.js?ver=f710d3cc99e7a55a0d6a5418f3cfe33c:9
        je https://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:78
        ph https://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:215
        lh https://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:126
        O https://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:121
        ze https://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:118
        mg https://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:53
        unstable_runWithPriority https://example.com/wp-includes/js/dist/vendor/react.min.js?ver=16.9.0:26
        Ma https://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:52
        mg https://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:52
        V https://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:52
        Sb https://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:213
        Mg https://example.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0:85
        e https://example.com/wp-includes/js/dist/data.min.js?ver=e80048e7b309581a40e44b8bd8aaba41:2
        t https://example.com/wp-includes/js/dist/data.min.js?ver=e80048e7b309581a40e44b8bd8aaba41:2
        o https://example.com/wp-includes/js/dist/data.min.js?ver=e80048e7b309581a40e44b8bd8aaba41:2
        o https://example.com/wp-includes/js/dist/data.min.js?ver=e80048e7b309581a40e44b8bd8aaba41:2
        b https://example.com/wp-includes/js/dist/data.min.js?ver=e80048e7b309581a40e44b8bd8aaba41:2
        p https://example.com/wp-includes/js/dist/data.min.js?ver=e80048e7b309581a40e44b8bd8aaba41:2
        a Redux
        I https://example.com/wp-includes/js/dist/data.min.js?ver=e80048e7b309581a40e44b8bd8aaba41:2
        N https://example.com/wp-includes/js/dist/data.min.js?ver=e80048e7b309581a40e44b8bd8aaba41:2
        dispatch https://example.com/wp-includes/js/dist/data.min.js?ver=e80048e7b309581a40e44b8bd8aaba41:2
        Redux 8
        n https://example.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4:1
        T https://example.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4:1
        t https://example.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4:1
    react-dom.min.js:103:487

    Apparently react-dom.min.js ships with WP 5.4. Toggling off plugins didn’t seem to help.

    Content still exists and can be modified in Code Editor.

    Looking at the 5.4 master list, it seems that the Stargazer theme is having a block editor issue. That’s probably my problem, as I’m using that theme.

    Hello everyone, I solved all my issues the other day after a few hours of doing tests and debugging….

    I tried a plugin to downgrade my wordpress version …being almost sure it was the solution…because my problem started after updating to the new wordpress…but even after downgrading my problem was still there…so I was surprised…

    Then, I tried deactivating ALL MY PLUGINS > to see if I could edit and when doing that : I saw that I could edit the page >>> meaning the problem was from one of the plugins….

    I ended deactivating all my plugins ony by one in order to find the culprit ….

    as far I am concerned, I think my problem was the plugin “Remove WordPress Overhead” (not sure why though…)

    Anyway, I wasted few hours of my life but I can edit again my pages.. like before.

    If you still have the issue > tried deactivating ALL your PLUGINS and reactivate them one by one….

    I’m happy you find the solution. Thank you for your solution.

    Confirmed that the Stargazer theme is causing the issue. Switching to Twenty Seventeen made all the blocks with error messages not have errors. So anyone having this issue might want to try switching momentarily to a well supported theme with recent updates to see if your current theme is causing the problem.

    Adding this code to your Stargazer child theme’s functions.php file should correct the block error:

    
    add_action( 'after_setup_theme', function() {
    	remove_theme_support( 'editor-color-palette' );
    } );
    

    Just noting that Stargazer is an older theme that does not have full support for block editor styles. I am unsure if I’ll update it at this point since WordPress has changed so drastically in these last few versions. I love the block editor, but a full update like this would be a massive undertaking that I probably won’t have time for, at least in the near future.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.