Support » Plugin: WP eCommerce » Bug affecting Admin Menu Collapse

  • Resolved milkboy31

    (@milkboy31)


    ◾WordPress version: 4.4
    ◾WP eCommerce version: 3.11.2
    ◾Gold Cart version: n/a
    ◾Theme: Avada, Exodus
    ◾I did this: Deactivated all plugins on multiple sites… clicked the “Collapse Menu” button at the bottom of the left menu in the admin control panel of WordPress. The button works fine. Click it again to expand, it does so fine. Once I enable this WP ecommerce plugin and click the “Collapse Menu” button, nothing happens. If I refresh the page, it refreshes in a collapsed state. If I click to expand it, it never does. Refreshing doesn’t help. It is stuck collapsed. I can then disable this plugin and it expands fine.

    I have tried mac/pc, safari/firefox/ie/edge… all show the same behavior. I have recreated this on multiple sites I manage as well.

    You can manually fix the issue by doing this:
    1) Open PHPmyAdmin
    2) Choose the site’s database
    3) wp_usermeta table
    4) wp_user-settings meta_key
    5) delete ‘&mfold=f’ from line

    That &mfold=f value is supposed to set to &mfold=0 when you expand it again, but it doesn’t. Manually changing it to 0 doesn’t work either… deleting the value does, but sometimes takes multiple tries for it to not be overwritten again with f back in there… very strange.

    I’m not sure the issue runs so deep with this plugin messing with the above mentioned table meta_key and such… but maybe it does? My guess is that it’s just interfering with the right javascript or whatever is being used to collapse/expand the menu and send the right commands to edit the database.

    Thoughts? Need any more info or testing?

    ◾I expected this:
    It’d work as expected. 😉

    https://wordpress.org/plugins/wp-e-commerce/

Viewing 15 replies - 1 through 15 (of 15 total)
  • Bump. Can anyone else with this plugin confirm the same issue on your site? I’ve replicated it on two sites but they are both on the same server. I want to see if this is a server compatibility issue (PHP version or something).

    Just try to collapse the admin bar (bottom option on the left side toolbar) on the WP Admin back-end… then try to expand it again. If it isn’t working as expected, disable this plugin and try it again. Once you have it where you want it, re-enable this plugin.

    Can you replicate the issue?

    I found your post because it started happening to me today, I tried changing the mfold option but it didn’t seem to work. Will let you know if I can get it working.

    Try changing the mfold option to &mfold=t, that worked for me! Thanks.

    So before doing the change to mfold=t, did you find the same repeatable issue being caused by this plugin? Or was your site doing this regardless of this plugin?

    Also, any idea what the t option means? f obviously means fold. 0 means disabled… what’s t?

    So… still no reply from the plugin author. Bug still exists. Can anyone else confirm?

    Yea just tested this and caused the stuck menu, deactivated WPEC and got it back. The plugin authors appear to answer easy questions but ignore the difficult ones…

    Plugin Author Justin Sainton

    (@justinsainton)

    Hi all,

    We’ve logged this issue here: https://github.com/wp-e-commerce/WP-e-Commerce/issues/2028

    Please note: we do the best we can with the time we have on these support forums. It’s a free, open source plugin – and support provided in these forums is provided for free, as we are able to provide it. Of course we answer the questions that we’re able to answer easily and quickly first. 🙂

    Just confirming that I am having the same problem. Menu collapse not working as described by milkboy31. I tried the same troubleshooting; disabling/enabling each plugin. With this plugin enabled, menu collapse is broken; with it disabled, it works fine.

    Justin:
    Thanks for working on this issue. Looking forward to a resolution – clients are not happy with a broken admin menu!

    Milkboy31 and stevotivo:
    Is your &mfold workaround working while the authors try to fix this? Can you supply more details? Where do I apply this workaround? Thanks!

    1 – Edit wp-admin/admin-header.php with Notepad++
    2 – Line 139, change
    if ( get_user_setting('mfold') == 'f' )
    to
    if ( get_user_setting('mfold') == 't' )
    3 – Save, upload file on server

    done 🙂

    If ‘t’ doesn’t work, try ‘o’ or ‘0’ instead

    Thanks drageoco, the above trick worked. I changed (‘mfold’) == ‘t’ That fixed it.

    Problem happened again after a WP update (to v4.5.2). Found another solution here : http://wordpress.stackexchange.com/questions/166599/how-to-make-admin-sidebar-menu-always-be-collapse-by-code

    To make the admin sidebar menu always be collapsed, try adding the following code in the functions.php file of your child theme, or add it in your site using a plugin like Code Snippets, or Add Actions and Filters.

    global $user_ID;
    $user_fold = get_user_meta( $user_ID, 'wp_user-settings', true );
    $exp_array = explode( "&", $user_fold );
    $search_array = array_search( "mfold=o", $exp_array );
    if ( $search_array ) {
        $exp_array[ $search_array ] = "mfold=f";
        $exp_array = implode( "&", $exp_array );
        update_user_meta( $user_ID, 'wp_user-settings', $exp_array );
    }

    Hey guys.
    There will be a 3.11.3 release for WP eCommerce that should adress that very weird bug .
    Should be out soon

    whitelamp

    (@whitelamp)

    We have a site still on 3.11.1 and got hit by this – I ended up updating wp_user-settings in the wp_usermeta table in the database.

    Or you can add this in the function.php file

    function make_menu_unfolded() {
        print '<script>jQuery(document).ready(function(){jQuery("body").removeClass("folded")})</script>';
    }
    add_filter('admin_head', 'make_menu_unfolded');
Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Bug affecting Admin Menu Collapse’ is closed to new replies.