Support » Plugin: Multisite Language Switcher » Bug: adding translation for saved pages always links to “post” as type

  • Resolved Arno Welzel

    (@awelzel)


    I have this on all sites where I use that plugin at the moment (at the moment about 10 sites).

    When I create a new page, MSLS offers to create a version for other languages with https://mysite.example/wp-admin/post-new.php?post_type=page (where page is a page or in some cases a custom post type).

    However as soon as the page was saved, the parameter post_type is missing and clicking on the “Create a new translation…” button does not work any longer as it will only create a new post but NOT the type I have currently opened.

    However the drop down list is still aware that I don’t edit a post but a page (or any other custom post type) and lists pages (or any other custom post types) in the other language. It’s just the link to add a new translation which does not work.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter Arno Welzel

    (@awelzel)

    I have identified the cause of this and created a pull request:

    https://github.com/lloc/Multisite-Language-Switcher/pull/191/files

    Thread Starter Arno Welzel

    (@awelzel)

    Since the pull request is merged, this issue will likely be fixed with the next update.

    Plugin Author Dennis Ploetner

    (@realloc)

    Thanks for the PR. I’m testing it a bit and will then prepare version 2.5.6.

    rovente

    (@rovente)

    The issue persist importing content from language with version 2.5.8

    Thread Starter Arno Welzel

    (@awelzel)

    What do you mean exactly with “persist importing content from language”?

    rovente

    (@rovente)

    Hi Arno, these are the steps to reproduce:
    – In the main blog (italian for me) edit the home page
    – add the english home page as translation from the top-sidebar select
    – click on the english flag of the select to edit the english home page
    – in the english home page, select import content from italian home page
    – on save, the content is correctly imported with all the acf in place, but the home page is become a post type in draft. So the import work only on posts, and broke all the others post types.

    Thanks

    Thread Starter Arno Welzel

    (@awelzel)

    I don’t have “import content” anywhere. Is this provided by a plugin?

    Edit: found it – one has to enable this first in MSLS.

    Well I am not the author of MSLS, but maybe I find a solution. If so, I will add a pull request for the fix as well.

    • This reply was modified 2 weeks, 6 days ago by Arno Welzel.
    Plugin Author Dennis Ploetner

    (@realloc)

    Hey all, yes this is additional functionality that is currently without much testing. I will have a look into it.

    Thanks all, find a solution would be awesome.
    Is the most blocking feature at the moment, however I must find another solution for the site translation.

    Thread Starter Arno Welzel

    (@awelzel)

    Copying the original post content does not work? Even Gutenberg allows Ctrl-A followed by Ctrl-C to copy the content to the clipboard. Or do you use a page builder like Elementor?

    Hi Arno, I use classic editor and ACF on a headless wordpress, so I’m interested only on backend and it’s graphQl data exposed.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.