[BUG] 2.9.2 to 3.0 standalone and MU->MS (Subdomain) BIG problems (4 posts)

  1. gazouteast
    Posted 6 years ago #

    The following bug reports refer to three different hosts, and all reference installations in "add-on" domains (i.e. not the main hosting account domain names) - all DNS and Vhosts and other WPMU requirements were / are set correctly, and all affected domains were running perfectly under WPMU 2.9.2 / WP 2.9.2 standalone. All WPMU installs were subdomain installs.

    I have tried to auto-upgrade (from wp-admin) from 2.9.2 (single blog and WPMU) to WP 3.0 (single blog and WPMU) and had the same results each time ....

    Issues common to all upgrades -

    - loss of images display in admin, media uploader (after upload), and on page/post editor, and on published and draft posts (both preview and published)
    - Fix?
    - Delete completely (or comment-out / rename for roll-back use) the entire WP / WPMU 2.9.2 .htaccess content.
    - Insert the standard WP 3.0 .htaccess content posted all over the wp.org forums - be sure to choose the CORRECT .htaccess content to insert (single blog or multi-site? subdomain or subdirectory setup?).
    - PROVIDED the server has fread() and fopen() enabled on the server
    - if any of those three are not done, images will not display.

    <u>Note:</u> fread() / fopen() are going to cause deprecated-class problems on PHP 5.3.x servers (see php.net notes around those for PHP 5.3+).

    Issues common to all WPMU (subdomain) to 3.0ms upgrades -

    - Sub-blogs display only the theme and the sidebar / menu lists of categories, pages, posts (plus the content quantity is enabled),
    - - the actual posts and pages, single-posts, category_pages, tags_pages, archives, etc., pages all return "nothing found" 404 pages.
    - In admin, looking at any of the page, post, category, tag etc., edit/manage lists does the same - it does show how many are in the database at the top of the list, but returns a "nothing found" / "list is empty" short message immediately under the top of list buttons, and does not display the expected data.
    - Fix? I've tried everything I can find that is suggested in these forums, at trac.wp.org, and on the WPMU and BuddyPress forums - nothing cures this. My multi-site domains are completely non-functional except for the home blogs on each, which still work.

    Sample site to view this happening = http://checkedbyyou.com (home blog) and http://webhosting.checkedbyyou.com (sub-blog) - this is a site I began working on under WPMU 2.9.2 (subdomain install) and used to first test the auto-upgrade to WP 3.0 - it has just enough on it to show the problems described above.

    The prime cause <u>appears to be</u>
    - WP failing to correctly update the .htaccess file (both bug sets)
    - plus the switch from wp-content/blogs.dir.php to wp-includes/ms-blogs.php (for MU / MS installations' sub-blogs)

    = there is something broken in either the new ms-blogs.php and/or the htaccess updater.

    Does anyone have a (working) fix to get the sub blog content displaying?

    webhostingpad.com (cPanel)
    - Linux 2.6.18-194.3.1.el5
    - MySQL 5.1.46
    - Apache 2.2.14
    - PHP 5.2.12

    unlimitedwebhosting.co.uk (Cloud / Plesk)
    - Linux
    - MySQL 5.0.77
    - Apache ?
    - PHP 5.2.13 (Zend: 2.2.0)

    namecheaphosting.com (cPanel)
    - Linux 2.6.18-194.8.1.el5
    - MySQL 5.0.90-community
    - Apache 2.2.15
    - PHP 5.2.13 (Zend: 2.2.0)

  2. James Huff
    Support Team Rep.
    Posted 6 years ago #

    I'm not entirely sure this is a general bug, as it would be affecting almost everyone who upgrades, but I do see something like this reported a few times each day, so it's probably configuration-specific. In that case, please report your bug through the proper channels and reply here with a link to the ticket.


  3. gazouteast
    Posted 6 years ago #

  4. gazouteast
    Posted 6 years ago #

    Updating - I called out the incorrect must-have file names in the OP

    It should be -

    - PHP function readfile() MUST be enabled for WordPress MU + BuddyPress installs

    Sorry about any misleading


Topic Closed

This topic has been closed to new replies.

About this Topic