Support » Plugin: WP Mailto Links - Protect Email Addresses » Buffering Error on WP4.5.1 with "Yes, convert plain emails to mailto links"

  • Hi There,

    After updating to WP4.5.1 the plugin stopped working with “Yes, convert plain emails to mailto links” option enabled.

    It crashes the whole website and just throwing a white screen with the following error:
    “Fatal error: Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0”.

    Tested on WP4.5.1, WP Mailto Links v2.1.1, Twenty Fifteen theme and WP Mailto Links being the only enabled plugin.

    Any help would be appreciated.

    Thanks.

    https://wordpress.org/plugins/wp-mailto-links/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Does the error and white screen only appear when you have the option “convert plain emails…” enabled?

    Yes, when you are not logged in.

    However, with more testing I have discovered that if you are logged in AND “Yes, protect plain emails with protection text *” option is selected AND there is a form on a page that automatically adds user’s email to an email field, then the white screen and the error appear as well.

    I tested the same circumstances (also same wp version and fiftheen theme), also tested form field with email, but no error or white screen.

    Maybe other specific settings?

    Hi,

    I do have the same Problem … Using WP 4.5.1 and the Colorlib Sparkling Theme.

    Regards
    Jens

    Jens and Olgri, I cannot reproduce, so I need more clues.

    I confirm I have similar issue when “Yes, convert plain emails to mailto links” option is on, no matter if I am logged in or not.

    Peter

    The problem is probably related to a bug that only appears in PHP 5.3. Please update to version 2.1.2.

    Technical explanation: I used the $this reference within a closure and that’s only supported for PHP 5.4+.

    I have setup an environment with 5.3 and hope these type of bugs will never be included within a release again. I am sorry for the burden!

    Hi!

    The new Version seems to work!
    Many thanks for your quick response and fix 🙂

    Habe a nice weekend
    Jens

    Great!
    Thanks, you too. 😉

    Yep, it help with my issue too.

    Thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Buffering Error on WP4.5.1 with "Yes, convert plain emails to mailto links"’ is closed to new replies.