Support » Plugins » [BuddyPress] Unable to Register New Network Sites Post Install

  • Lee


    I added BuddyPress to a freshly installed fully working multi-site with maybe 6 other plugins in it. Since adding BuddyPress I’ve been unable to properly register new sites in the Network. The network worked flawlessly prior to the installation of BuddyPress.

    Here is what happens when I add a new site:

    • I create the new site in Network Admin,
    • WordPress registers the site’s database tables,
    • I try to view any of the site’s frontend or backend and I receive a message that the site cannot be reached by my browser.

    When I run Update Network I get the message:

    “Warning! Problem updating Your server may not be able to connect to sites running on it. Error message: Couldn’t resolve host ‘'”

    The site is hosted at Hostgator with shared hosting. The same server works well with 8 other domains installed on it; including multi-sites. Wildcard subdomains are configure for this domain – it worked perfectly before BuddyPress was installed.

    Removing BuddyPress hasn’t resolved the issue: I am still unable to properly register new sites.

    I have reinstalled all WordPress files but those in /wp-content and .htaccess and wp-config.php. This was done by uploading the latest WordPress version, removing the old files and unpacking the new files. .htaccess and wp-config were not changed by the BuddyPress install – I compared them to the standard files to check. A blank .htaccess does not resolve the issue, nor does adding “DirectoryIndex index.php” to it.

    I can create a subdomain for the registered domain manually whereupon the addon site will work – the host is then found.

    My suspicion is that BuddyPress altered the part of the database that handles virtual hosts/domains. I don’t know where in the database this might be done.

    I have considered merging relevant tables from a fresh install of WordPress multi-site to try and resolve the issue but I don’t know which tables need to used – I might just do them one by one to see what happens.

    This is a test domain and I can completely redo the site but I’m keen to understand what has happened and how I might fix it in case it happens again. This is the second time I’ve known BuddyPress to cause this error on a multi-site setup. Please help 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[BuddyPress] Unable to Register New Network Sites Post Install’ is closed to new replies.