[resolved] BuddyPress Template Pack - JS / AJAX are not working (10 posts)

  1. Tosh
    Posted 6 years ago #

    When I'm on the activity page (http://mysite.net/activity) or any page that has "activity".
    The filters like the following just change all the activity to be blank, instead of "filtering" it.

    * All Members (391)
    * My Friends (1)
    * My Groups (2)
    * @testuser Mentions

    The dropdown filter box does not work either. Just changes all the activity to blank. Everything else in the buddypress works fine.

    I switched the theme to "BuddyPress Default 1.2.1 by BuddyPress.org" it worked again, so something in the BuddyPress Template Pack is not bringing over the JS / AJAX from the default theme. Any ideas?

    1. Which version of WP/MU are you running? 2.9.1 Single WP
    2. Did you install WP/MU as a directory or subdomain install? http://www.mysite.com
    3. If a directory install, is it in root or in a subdirectory? root
    4. Did you upgraded from a previous version of WP/MU? If so, from which version? No
    5. Was WP/MU functioning properly before installing/upgrading BuddyPress (BP)? e.g. permalinks, creating a new post, commenting. Yes
    6. Which version of BP are you running? Version 1.2.1
    7. Did you upgraded from a previous version of BP? If so, from which version? No
    8. Do you have any plugins other than BuddyPress installed and activated? Yes
    9. Are you using the standard BuddyPress themes or customized themes? Using BuddyPress Template Pack
    10. Have you modified the core files in any way? Yes, to fix the avatar upload issue:
    bp-core-avatars.php line 389

    if ( !$path = get_option( 'upload_path' ) )
    $path = WP_CONTENT_DIR . '/uploads';

    if ( !$path = get_option( 'upload_path' ) )
    $path = WP_CONTENT_DIR . '/uploads';
    $path = ABSPATH . $path;

    ...and report back?


    11. Do you have any custom functions in bp-custom.php? No
    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in? Not using bbPress.
    13. Please provide a list of any errors in your server's log files. - Nope, shared server.
    14. Which company provides your hosting? Hostgator


  2. Tosh
    Posted 6 years ago #

    Any ideas?

  3. miri
    Posted 6 years ago #

    I had the same problem until I changed my main content div container to have an id of "content". That cleared it up.

  4. Tosh
    Posted 6 years ago #

    No change. The first 2 divs for me are:

    <div id="container">
    	<div id="content">
  5. Tosh
    Posted 6 years ago #

    Any other thoughts? I really want the filter options to work ...

  6. @mercime
    Volunteer Moderator
    Posted 6 years ago #

    Do ask at BuddyPress forums as well - http://buddypress.org/forums/ use same username and password

  7. Tosh
    Posted 6 years ago #

    I have actually no solution just yet. When I find a fix I'll update this thread.

  8. Tosh
    Posted 6 years ago #

    Ok I disabled all the plugins except the following:

    BuddyPress Version
    BuddyPress Template Pack Version 1.0.2
    Private WP 2 Version 1.0

    I'm using this theme - Fusion 3.0.4 by digitalnature

    Still not working ... so it's either the BuddyPress Template Pack or the Theme ... where do I go from here?

  9. Tosh
    Posted 6 years ago #

    Ok, I tried the default wordpress theme and move the templates files using the BuddyPress Template Pack.

    Now it's filtering correctly. Dang, so what do I check in my theme ?

  10. Tosh
    Posted 6 years ago #

    Turns out it was this in my theme causing it to break:

    jQuery.fn.fadeOut = function(speed, callback) {
     return this.animate({opacity: 'hide'}, speed, function() {
      if (jQuery.browser.msie) this.style.removeAttribute('filter');
      if (jQuery.isFunction(callback)) callback();

    Thanks to Boone Gorges over at the BuddyPress forums to finding that issue!


Topic Closed

This topic has been closed to new replies.

About this Topic