Support » Fixing WordPress » Buddypress not working

  • Whenever I install buddypress on WP I get errors. First my whole website including WP was white and now I just get a message saying:

    Fatal error: Call to undefined function get_blog_option() in /home/www/ on line 566

    When it was blank I spoke to my host and they said they got the same thing. The problem goes away after I delete it via an FTP client. Can someone help?

Viewing 8 replies - 1 through 8 (of 8 total)
  • I’ve got the same issue, exactly the same message. Which version of WordPress and BuddyPress are you using? I’m using:

    WP: 2.8.6
    BP: 1.1.3

    I’ll post back if I find anything useful.


    The newest one

    so same as you


    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    Happy Holidays! And read the requirements


    There is a way to run BuddyPress without WordPress MU but for now you must have MU installed or it just wont work.

    Actually it WILL work with single user WordPress now. Exciting news! You have to use the trunk version of BuddyPress, but I’ve tried it with WP 2.9 and it seems to be working just fine. I have info on how to install it here:

    Have installed BuddyPress to my single user blog. The bar comes up across the top, but the links all go to 404.

    Have narrowed it down to the problem, I think. My hosting requires that instead of using pretty permalinks, I have to use not-quite pretty permalinks. Like this, for example:

    The “index.php” has to always be there apparently. Does anyone know of a workaround?

    I was having trouble getting things to work until I installed a version on a subdomain ( instead of Not really sure why this worked, but it did.

    (If you’re interested, the main problem in my case was that people would register for the site, appear in the Users page of the WP-Admin, but not display in the Members page of the website itself. Moreover, once users registered, they were telling me that nothing actually happened—they would register and then be re-directed to the Home page without being recognized as “logged in.” Super frustrating!!)

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Buddypress not working’ is closed to new replies.