Support » How-To and Troubleshooting » Buddypress mucking up WordPress 3.0

Buddypress mucking up WordPress 3.0

  • Hi everyone,

    I just installed Buddypress on WordPress 3.0. I’ve noticed, since installing the plugin and configuring the options in my admin folder, that I can see my front page fine. But if I try to go to any other page (forums, activity, members, etc.), I get a message that tells me the page doesn’t exist.

    I had this problem before, when I tried to configure .htaccess for the multiple blog option on 3.0. The same thing happened, and I realized that .htaccess had a line of code that was messing me up. I simply #’d the “RewriteEngine On” line and everything went to normal.

    Is there a similar line in the Buddypress plugin that I can # to resolve this issue?

Viewing 15 replies - 1 through 15 (of 18 total)
  • BTW, I’m using Buddypress



    Volunteer Moderator

    BuddyPress is compatible with WP/MU 2.9.2, that’s it. Per BuddyPress roadmap – WP 3.0 support will come in BP 1.3 version.

    I had to regenerate my permalinks by saving to default, then back to custom structure when I had the same problem. That solved it for me, BP with WP3.0


    I tried what you suggested. The links worked on default, but when I went back to my custom structure, it stopped working.

    Any other suggestions?


    Do you know when BP 1.3 is coming out?

    Without RewriteEngine On, permalinks won’t work, so it’s either/or with that one.

    I have 3.0 and BP working with other subfolders, no issues.

    Is this 3.0 single site or multi? What’s in your .htaccess for WP right now?


    My 3.0 is multi (which is why I got Buddypress). I’m assuming you need the multi activated to run Buddypress.

    Here’s my .htaccess

    # RewriteEngine On
    #RewriteBase /
    #RewriteRule ^index\.php$ – [L]

    # uploaded files
    #RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    # RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    # RewriteCond %{REQUEST_FILENAME} -f [OR]
    #RewriteCond %{REQUEST_FILENAME} -d
    # RewriteRule ^ – [L]
    # RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    # RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    # RewriteRule . index.php [L]

    You do not need MU or MS to run BP 🙂

    All that stuff you commented out is … well, that’s what makes your blog work. That’s how it knows to redirect your pretty permalinks correctly. Un-comment that out.

    Does Buddypress, without the MU capabilities of 3.0, allow users to run their own blogs? I want both social networking and blog capability.

    No, but the blogs has nothing to do with BP.

    BuddyPress ONLY does the social networking. WPMU (or MultiSite) does the blogs bit.

    Anyway, if you’re keeping MultiSite, you need that .htaccess code back or ain’t nothing working.

    well, I’m fine until I try to update my permalinks. I get a CGI error until I delete both Buddypress and the .htaccess file.

    BuddyPress will never work without Permalinks (IIRC), and if you can’t use Permalinks….

    What’s the FULL CGI error when you enable permalinks and use the .htaccess file? It’s likely a server config issue. Are you using IIS/Windows as your server?

    no, my server is a campus server.

    It’s a pretty generic CGI script Error:

    “The server encountered an internal error and was unable to complete your request. Error message:
    The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.”

    Maybe the server doesn’t have something installed?

    It’s a campus server for the University I work for.

    What OS is the server running? I ask because IIS (aka Windows Servers) have weird permalinks issues. That’s the most common reason for weird issues like this.

    Is there anything else in your .htaccess?

    If you make a blank one, can you set the permissions to 755 and try resetting permalinks in WP?

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Buddypress mucking up WordPress 3.0’ is closed to new replies.