Support » Plugins and Hacks » BuddyPress Album

BuddyPress Album

  • I just installed the latest version of BuddyPress Album+ (bp-album), but it wont accept any photos that I try to upload. I get an error message that says: “Privacy option is not correct.” and also this error message at the top of the page:

    “Warning: Division by zero in /home/divineea/public_html/main/wp-content/plugins/bp-album/includes/bp-album-templatetags.php on line 79”

    Further, there doesn’t seem to any admin options, which apparently is supposed to exist.

    Any ideas what the problem could be?

Viewing 15 replies - 1 through 15 (of 36 total)
  • Same thing happening to me.

    The admin panel is under the buddypress menu in the backend.

    Please write the values you are using and also wp and bp versions.

    WordPress version is 2.9.2 and BP is 1.2.1
    Same issue with the division by 0, and also this one when you try to upload:

    Warning: constant() [function.constant]: Couldn’t find constant BP_ALBUM_MAX_PRIV0_PICTURES in /mounted-storage/home84c/sub001/sc45645-VVED/corjacollective.com/wp-content/plugins/bp-album/includes/bp-album-screens.php on line 284

    and below that, in a red box, “Privacy option is not correct.”

    I’ve added values on the admin for all fields, tried 100 on all, and 10 on all, but the errors remain.

    Thanks for the plugin btw, can’t believe it’s not on BP by default!!

    0.1.5 should fix all these problems

    Thanks Francesco, the previous errors are gone with the new version, but now when you try to upload an image, this error comes up:

    There were problems saving picture details.

    I’ve tried playing around with all the options on the album admin but nothing changes this. Any ideas to what may be causing this?

    Thanks again!!

    WordPress version is 2.9.2 and BP version

    I just installed the latest version, 0.1.5. Now I get the same message as celsosoares: “There were problems saving picture details.” I tried the different Visibility options, but that did not make a difference.

    Okay, I will get on this right away. If it’s related to the 0.1.5 source I should have a fix in an hour or two.


    @celsosoares and @bpyogi

    I can’t reproduce the problem you guys are experiencing. It works perfectly on my development machine.


    I need to know exactly what you did to get the problem to happen.

    1) Delete the entire plugin folder.

    2) Download it again from the plugin repository.

    3) Copy the fresh plugin folder to your plugins directory

    4) Activate it

    5) And from that point on, tell me “mouse click by mouse click” how you get to the “There were problems saving picture details.” error.



    Did as you requested and still get the same issue.

    After activating the plugin I went into the site, clicked on my profile, then on Album, then upload and chose a jpg (also tried with a gif, and also tried different filesizes and dimensions). I then get the error, in a red box saying: “There were problems saving picture details.”

    I did notice something odd. After deactivating and deleting the plugin folder, and then uploading a fresh copy and activating it, the admin page still has the same values that I had entered previously, for “Max total images allowed in a members album”, etc, instead of the ones you set by default. Maybe this is related? Do I need to delete something on the database?

    Thanks again for your support mate!

    Thank you for all hard work on this plug-in I think it would be one of the best Buddypress plug-ins around. I’m having the same problem. When I try to upload a picture I get a load error I can see that the pictures uploading to this folder /wp-content/uploads/album/1 but it won’t go to the next page and display the picture and of course I’m using the latest updated WordPress and Buddypress. I also just installed WordPress and Buddypress new today. So I don’t think it has anything to do with WordPress or Buddypress.I followed all the directions for installing the plug-in just like in the readme file.

    Thanks again for your support

    @celsosoares, @courselle – what I need both of you guys to do is delete your bp-album plugin folder, download *version 1.3* of the plugin, and install it.

    You can get version 0.1.3 here: http://wordpress.org/extend/plugins/bp-album/download/

    Do NOT upgrade to version 0.1.5 if WordPress asks you to.

    After installing it, do you still get the same error?

    @celsosoares – That’s on purpose. We’ve made the plugin configuration and debug data stay in the WordPress settings database even if you delete the plugin, so we can figure out what happened even if something goes very wrong. Don’t worry – it takes up less space than this paragraph and we’ll remove it in the next version .. 🙂


    I am getting same problem. with newest version.

    I just did what you asked, and yes, Problem continues even after deleting newest version and installing 0.3.1 version/ I will empty cache and see if that helps.

    No help, even after emptying cache. Any other suggestions or should I simply delete the plugin?

    @jerryisrockin – Okay, good. That narrows it down.

    And… to: @courselle, @celsosoares, and @jerryisrockin

    1) Have you *ever* been able to upload an image using our plugin, or has it always not worked?

    2) I need you to try and upload a picture to an article on your blog through WordPress. Does the upload work, and does the picture show up in the article.

    3) What’s your level of tech skill (do you know what phpMyAdmin is?) and how much free time do you have today.

    All three of you and anybody else having this problem: Would you like to work with me “live” to debug this?


Viewing 15 replies - 1 through 15 (of 36 total)
  • The topic ‘BuddyPress Album’ is closed to new replies.