Support » Plugin: Hummingbird – Optimize Speed, Enable Cache, Minify CSS & Defer Critical JS » BuddyPress 9.0.0 Signup Fields and Redis

  • Resolved Nifty



    When Redis is enabled and used in Hummingbird, there is a problem/conflict with the new BuddyPress 9.0.0 version. When adding a new field and adding it as a signup field at the same time, it does not add it to the “Signup Fields” tab, which it should do. We have also applied the bp_pages exclusion, as stated here in the Redis section – but this does not have any effect on this issue.

    To recreate the problem, follow these steps:

    Go to Users > Profile Fields > Add New Field > Enter info and select “Use this field in the site registration form.” > Save

    This new field should now show up in the “Signup Fields” tab immediately, too. However, this does not happen. With Redis not connected, everything works fine.

    If this could be looked into, that would be great.

    Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Adam – WPMU DEV Support


    Hi @niftythree

    I hope you’re well today!

    We’ve just tested this on a test setup with newest BuddyPress and Hummingbird, with Redis connected and I’m afraid we weren’t able to replicate the issue.

    Can you tell me, please, if there’s any other/additional cache than Hummingbird and Redis involved? By this I mean for example: some additional server-side cache, another caching plugin, cache on CDN such as e.g. CloudFlare etc?

    Can you confirm for sure (with your host) that Redis is working fine?

    Also, you mentioned that this is with new BuddyPress so with previous releases it worked fine for you (with Hummingbird connected to redis) and only started upon BuddyPress update or maybe upon Hummingbird update?

    Kind regards,

    Thread Starter Nifty


    Hi Adam,

    Thanks for your reply.

    No, there are no other plugins involved. We’ve also tried this with a new setup and still face the issue. Once Redis in Hummingbird is disconnected (while Hummingbird stays active), the fields all appear in the “Signup Fields” tab. There is no CDN or server-side cache active, either.

    Yes, Redis is confirmed to be working fine. The new BuddyPress brought in the ability to add fields to the signup form, while keeping them in separate tabs. Based on that, I can say it was working fine before the new BuddyPress update (as there was no adding fields to the signup area feature).

    Thanks for your continued assistance.

    Thread Starter Nifty


    Just to clarify, the new setup we have is running BuddyPress and Hummingbird plugins only, on the default WordPress theme. All versions are the latest, including WordPress.


    Plugin Support Nithin – WPMU DEV Support


    Hi @niftythree,

    Thanks for explaining further. The Hummingbird only helps with integrating the website with Redis.

    On further testing, I was able to replicate what you have meant in the WP Dashboard side. However, this seems more specific to how the fields are added within the BuddyPress side. If the plugin doesn’t invoke the cache to get cleared the changes won’t show. If I clear the Redis cache the field does show up under the “Signup Fields” tab.

    I could replicate the behaviour with Hummingbird disabled and with a standalone Redis plugin like:

    It doesn’t seem like the issue is specific to Hummingbird and more with BuddyPress and Redis.

    Could you please check and see whether you could replicate the same above-mentioned plugin? This would confirm where to look at.

    I hope this helps in moving forward.

    Kind Regards,

    Thread Starter Nifty


    Hi Nithin,

    Thank you for your reply and looking into this.

    Yes, I can confirm this also happens when using the plugin you have linked above. Good to know that this is not a Hummingbird issue. I know this may be out of your scope but, in your opinion, would you say that BuddyPress is not reliable enough to be used with Redis at the moment?


    Plugin Support Dimitris – WPMU DEV Support


    Hello @niftythree

    Really can’t tell if this is a BuddyPress issue or a missing configuration in Redis caching. Probably reaching BP support could assist on that:

    You should also check with your hosting provider if there’s any other object caching mechanism that could be conflicting with Redis.

    Warm regards,

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.