WordPress.org

Forums

BruteProtect
[resolved] bruteprotect_warning (13 posts)

  1. gecko_guy
    Member
    Posted 1 year ago #

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, class 'BruteProtect_Admin' does not have a method 'bruteprotect_warning' in /home/mydomain/public_html/dev/wp-includes/plugin.php on line 406

    mydomain above is obviously my domain name

    http://wordpress.org/plugins/bruteprotect/

  2. Sam Hotchkiss
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Gecko Guy-- are you running 0.9.9.5 or 0.9.9.6? I just pushed an update meant to address this issue

  3. gecko_guy
    Member
    Posted 1 year ago #

    Hi Sam,

    I installed whatever the latest was (tonight), but I have deleted it again now.

    Sorry, have had an unbelievable run of bad luck with hackers of late.

    Was using Wordfence premium, but that just ate up all my CPU and was crashing the server, so as soon as I saw the error above I just deleted the plugin and switched to Limit Login Attempts.

    I am willing to try again on a test domain..

    Guy

  4. Sam Hotchkiss
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Guy-- sorry about the bug-- you caught us just as we were releasing a new version!

    Please do give it another shot-- the brute force attacks have moved to being cloud-based, so solutions like Limit Login Attempts aren't very effective against the latest attack vectors.

    Thanks,
    Sam

  5. gecko_guy
    Member
    Posted 1 year ago #

    Thanks Sam, I am always keen to see improvements.

    Will try it again, and once I am sure it is robust will also be very happy to make a donation.

    Thanks for the quick response!

    Cheers

    Guy

  6. gecko_guy
    Member
    Posted 1 year ago #

    Just to confirm that the error is no longer displaying with the update to 0.9.9.6

  7. Sam Hotchkiss
    Member
    Plugin Author

    Posted 1 year ago #

    Great, thanks! Sorry you caught it in flux :)

  8. Diac
    Member
    Posted 1 year ago #

    Same error just after I installed version 0.9.9.8. Fast update required! I'm under attack!

  9. Diac
    Member
    Posted 1 year ago #

    Thx :)

  10. dancriel
    Member
    Posted 1 year ago #

  11. esmi
    Forum Moderator
    Posted 1 year ago #

    @dancriel: As per the Forum Welcome, please post your own topic.

  12. dancriel
    Member
    Posted 1 year ago #

    Ok.

  13. Sam Hotchkiss
    Member
    Plugin Author

    Posted 1 year ago #

    We've resolved all of the issues at this point-- if you're still experiencing issues after updating to 0.9.9.9b, please post a new thread.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • BruteProtect
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.