Support » Plugin: WP Cloudflare Super Page Cache » Browser incompatibility

  • Resolved alx359

    (@alx359)


    At some point the plugin admin UI has become incompatible with Vivaldi (a nice Chrome clone), unfortunately. The issue is with the “Cloudflare API Key” field. It seems it has a tendency to forget that key value and from this the plugin setup wizard can’t be properly finished. In my case, it’s impossible to get the Worker injected and working, throwing an Invalid request headers (err code: 6003) all the time.

    EDIT: Even updating with Vivaldi already working (Worker) settings make the aforementioned issue still happen.

Viewing 6 replies - 1 through 6 (of 6 total)
  • EDIT:
    (Have deleted all the fluff as finally got a clue what’s going on.) The culprit seems in Vivaldi/Chrome password autocomplete that’s messing with the wizard/tabs of the plugin. Adding autocomplete="new-password" to the swcfpc_cf_apikey field has fixed the issue for me so far:

    \plugins\wp-cloudflare-page-cache\libs\views\settings.php line 233:

    <input type="password" name="swcfpc_cf_apikey" value="<?php echo $this->main_instance->get_cloudflare_api_key(); ?>" autocomplete="new-password" />

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @alx359,
    Yes, that’s great feedback. Autocomplete should be turned off for the API Key and API Token fields. I’m sure @salvatorefresta will implement in it in coming update.
    Here is an update on the autocomplete issue with chrome: https://stackoverflow.com/a/15917221/2308992

    Hello @isaumya,

    Thanks for acknowledging the issue, and for the reference.

    EDIT: Unfortunately, adding autocomplete="chrome-off", autocomplete="false", autocomplete="off" instead to the password-type swcfpc_cf_apikey field aren’t working for me in Vivaldi.

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @alx359,
    Does autocomplete="new-password" works?

    Yes autocomplete="new-password" works fine for me, and the only one that does so far in Vivaldi, from all those I have tried from the reference you linked. It still seems like one of the “hackish” and less universal workarounds, Unfortunately.

    Plugin Author Salvatore Fresta

    (@salvatorefresta)

    Hi guys,
    on next update the autocomplete for Cloudflare API token and API key fields is turned off.

    Thank you for the suggest!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.