WordPress.org

Support

Support » How-To and Troubleshooting » Browser Crashed During Update

Browser Crashed During Update

  • While I was updating to the latest version of WordPress, Firefox crashed and now I get this error message when I try to access my site.

    Fatal error: require() [function.require]: Failed opening required ‘/home/a5149571/public_html/wp-includes/class-wp-theme.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/a5149571/public_html/wp-settings.php on line 115

    Can someone please tell me how to fix this?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Unlucky timing for Firefox to crash!

    Try uploading a fresh copy of WordPress – excluding wp-content & wp-config.php. Then go to your admin panel and it might ask you to upgrade your database. This will only involve you clicking an “upgrade” button.

    I hope that fixes your problem, good luck!

    I deleted everything except wp-content and wp-config.php and uploaded a fresh copy of WP minus those two things. I restored my database and my site now opens but all I get is my home page. I have around 40 pages on my site that are not showing up. Please tell me I can fix this.

    Can you post your site URL?

    I think you may have messed up your .htaccess file.

    Is there a way to fix this. I can log into my dashboard and all my posts are still there. They simply won’t open in my browser. This is my first website and I don’t know a lot about html.

    It seems it can be a case malware, if this report can be believed: http://sitecheck.sucuri.net/results/hoodiabuzz.com/

    You may conduct further checks and find out.

    Okay, it looks like all my widgets are gone from my side bar. I think I can just recreate those and I’ll be okay, unless someone has an easier option. Thanks for all your help either way.

    Oops i forgot to add that I added htaccess file from a backup and got all of my posts to show up. They just all show on the same page. http://hoodiabuzz.com/

    Problem resolved, thanks for all your help.

    What was it that fixed your site? Just so people can know if they come across this 🙂

    I did as you suggested and loaded a fresh copy of WordPress minus the wp-content, wp-config, and htaccess files and that made all my pages become available again. They all showed up on one post and all of my sidebar widgets were missing so I had to recreate the widgets in my sidebar so that they could be accessed individually. With your advice and a little work I’m back to where I was before. Thanks again.

    Glad to hear you’re up and running again! Your widgets should have been in the inactive widgets area.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Browser Crashed During Update’ is closed to new replies.
Skip to toolbar