Support » Plugin: W3 Total Cache » Browser cache – Blank page or incorrect page rendering

  • Resolved wordpresslover7

    (@wordpresslover7)


    For a week I have had the following problem with Browser Cache, which never had before (I did not change anything). The problem occures in Chrome, Firefox, edge.

    If browser cache is enabled, for the first time page load or sometimes even second one the results are sometimes as the following:

    – error – wrong page coding, cannot connect to server
    – blank page
    – page incorrecly rendered

    After reload or two everything works perfect. Most pages load correctly for the first time but the problem is random, do not refer to any specific page 100% sure.

    Now I disabled the browser cache via W3TC no to lose traffic on my blog.

    I will apracciate any help, but it looks like it’s 100% W3TC plugin problem.

    I use very popular Avada theme – the newest version.

    Server Modules & Resources:

    Plugin Version: 0.9.7.2
    PHP Version: 7.0.30;
    Web Server: Apache
    FTP functions: Installed (required for Self-hosted (FTP) CDN support)
    Multibyte String support: Installed (required for Rackspace Cloud Files support)
    cURL extension: Installed (required for Amazon S3, Amazon CloudFront, Rackspace CloudFiles support)
    zlib extension: Installed (required for gzip compression support)
    brotli extension: Not installed (required for brotli compression support)
    Opcode cache: Installed (OPCache)
    Memcached extension: Not installed
    Memcache extension: Not installed
    Redis extension: Not installed
    HTML Tidy extension: Not installed (required for HTML Tidy minifier support)
    Mime type detection: Installed (Fileinfo) (required for CDN support)
    Hash function: Installed (hash) (required for NetDNA / MaxCDN CDN purge support)
    Open basedir: On: /home/logicinfo2/:/tmp/:/var/tmp/:/usr/local/php56/lib/:/usr/local/php54/lib/:/usr/local/php55/lib/:/usr/local/php56/lib/:/usr/local/php70/lib/:/usr/local/php71/lib/:/usr/local/lib/php/
    zlib output compression: Off
    set_time_limit: Available
    SSH2 extension: Not installed (required for Self-hosted (FTP) CDN SFTP support)
    mod_deflate: Not detected (required for disk enhanced Page Cache and Browser Cache)
    mod_env: Not detected (required for disk enhanced Page Cache and Browser Cache)
    mod_expires: Not detected (required for disk enhanced Page Cache and Browser Cache)
    mod_filter: Not detected (required for disk enhanced Page Cache and Browser Cache)
    mod_ext_filter: Not detected (required for disk enhanced Page Cache and Browser Cache)
    mod_headers: Not detected (required for disk enhanced Page Cache and Browser Cache)
    mod_mime: Not detected (required for disk enhanced Page Cache and Browser Cache)
    mod_rewrite: Not detected (required for disk enhanced Page Cache and Browser Cache)
    mod_setenvif: Not detected (required for disk enhanced Page Cache and Browser Cache)

    WordPress Resources

    –/.htaccess: OK
    –/wp-content: OK
    /wp-content/uploads/—: OK
    Fancy permalinks: /%postname%/
    WP_CACHE define: Defined (true)
    URL rewrite: Enabled
    Network mode: No

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter wordpresslover7

    (@wordpresslover7)

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,
    What you set as cache control policy determines if the browser should load the new content or not. If you do not have validation selected, your browser waits the number of seconds you set in Expires header (or whatever max-age is set to).
    Go to Performance > Browser Cache and disable the expires header for HTML and other sub-boxes. Also set Cache-Control Policy to cache with validation. If you have disabled page cache for logged in users, that should be all you have to do.

    Thread Starter wordpresslover7

    (@wordpresslover7)

    Hello Marko,

    Now it is even worse. I followed your advice and disabled all boxes in HTML/XML section except gzip. Now all pages load wrong every time.

    My settings right now: https://i.imgur.com/AuIiF89.png

    I had to disbled browser caching again no to lose traffic.

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,
    Sorry, maybe I was not clear. Disable only expires header and leave everything else enabled as it was. Enable Cach control header and ser Cache Control policy:cache with validation (“public, must-revalidate, proxy-revalidate”)

    Thread Starter wordpresslover7

    (@wordpresslover7)

    Dear Marko,

    I did exacly as you told me. This does not solve the problem at all. I tested the results in Edge, Chrome, Girefox in private mode.

    After the failure, I also tried to change other browser options (CSS/JS) etc according to your guideline. Didnt help either.

    Do you want to investigate that problem from back-end?

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,

    Seems like his server cannot handle gzip well enough. minify takes pretty long, hence the page changing on every reload. This might be related to minify in combination with gzip. SO maybe you need to lower level of gzip compression which makes things less cpu-intensive.
    Disable Gzip Compression in Performance>Browser cache and see if the issue persists.

    Thread Starter wordpresslover7

    (@wordpresslover7)

    That was not possible as I got monster CPU VPS and had not such problems in previous versions of WP.

    I finally moved to Litespeed cache – works like a charm with full minification and gzip.

    Thanks for you help Marko.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Browser cache – Blank page or incorrect page rendering’ is closed to new replies.