Support » Fixing WordPress » Browser Attempts to Download RSS feed file

  • trivum

    (@trivum)


    I couldn’t find the answer to this in the archives.

    I was having problems getting my site in an RSS reader, so I went to this vaidator site: http://www.feedvalidator.org/check.cgi?url=

    They said I had three problems:

    1. I didn’t have a title (I’m using a logo gif) –> I put in a dot
    2. line 87 of wp-blog-header.php din’t have a hyphen between “Last Modified” –> I put one in
    3. my content typs was “text/html” and it probably should be something like “application/rss+xml” –> I changed it.

    It says it validates now, and I was able to get the feed in the RSS reader I was working with, but now when I click on the RSS link on my site it tries to download the file instead of rendering it in the browser. The RSS comment seems to work fine, though.

    Any suggestions?

Viewing 6 replies - 1 through 6 (of 6 total)
  • davestinner

    (@davestinner)

    What’s the URL?

    trivum

    (@trivum)

    Wow, quick reply.

    Here it is: http://www.vlogblog.com/

    Thanks for any help.

    davestinner

    (@davestinner)

    Feeds should not be served with the “text/rss+xml” media type
    Your feed appears to be encoded as “utf-8”, but your server is reporting “US-ASCII”

    That’s what I get when I try to validate your feed.

    trivum

    (@trivum)

    “Your feed appears to be encoded as “utf-8”, but your server is reporting “US-ASCII” “

    That’s what the validator said originally, but it said I needed to change that. When I did change it, it validated it, and only then could I get my RSS reader to accept the feed.

    The validator said I should change it to “application/rss+xml” so I did.

    What now? Any ideas?

    davestinner

    (@davestinner)

    When I look at my wp-rss2.php file, the content type is “text/xml”.

    trivum

    (@trivum)

    Ok, I changed it to “text/xml” and got the link back, but it wouldn’t validate. I went back and reread the validator suggestions and tried
    “application/xml” … Everything seems to work! I don’t know why mine won’t work with with “text/xml,” but if it works, it works.

    Thanks a lot for your help.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Browser Attempts to Download RSS feed file’ is closed to new replies.