Support » Fixing WordPress » Browse and Browse All does not work…

  • lifthere


    When i click Browse and Browse All it refreshes that little window to the main page of the admin. It does not give me the visual listing of files that i uploaded to that post or to the site.

Viewing 7 replies - 1 through 7 (of 7 total)
  • lifthere


    Can no one give me a hand with this?

    I also have this same issue.

    I am running on Windows 2003 SP2, IIS 6, PHP 5.2.5, MySQL 5.0.45, WordPress 2.3.1.

    Previously the upload and browse functionality worked fine with WordPress 2.0.2, since updating to 2.3.1 these functions do not work as mentioned in the post above.

    I have tried reinstalling my web infrastructure noted above (with the latest versions) and setup a new plain vanila WordPress site. This unfortunately has made no difference to the issue.

    I have carefully checked all permissions for the website including permissions on uploaded files and I’m reasonably confident that I have no issue in that area.

    I have tried using both Firefox and Internet Explorer 7, both browsers produced the same result.

    I have also tried the fix mentioned in this thread This unfortunately didn’t resolve the issue either.

    I am now fresh out of ideas as to where to go with this. My gut feeling is an issue with my PHP or MySQL configuration. Perhaps the ‘Browse All’ feature is calling one of the extra php funtions that I haven’t enabled? Perhaps MySQL is doing something funny like was indicated in the liked article?

    Anyway I would really appreciate some help, thankyou in advance.

    – Eluthria

    I have done a little more digging over this issue…

    I reinstalled with WordPress 2.2.3 and a clean database. In my environment the ‘Browse All’ function works correctly with version 2.2.3.

    I tried installing 2.3.1 and then swapping in the upload functions from 2.2.3 but this didn’t work.

    I have also examined the wp_posts table and compared the row details between 2.2.3 and 2.3.1; to my eye they look identical.

    I’d be very greatful if anyone could offer some further suggestions.

    – Eluthria

    I’m having the same issue with the “Browse All” button producing a frame with the Dashboard displayed in it. I’m on a windows 2003 server with IIS6. I’ve tested this with a clean install of 2.3.2 with no plug-ins; same error. On the hunt for a fix…

    I’ve managed to fix this and it’s pretty simple. The error basically happens because the URL reads like this:

    The problem is the default document is index.php and NOT upload.php for this folder.

    To fix this:

    1) Simply open IIS manager
    2) Right click on the particular website
    3) Click properties in the right click menu
    4) Once in there, click on the Documents tab.
    5) Add upload.php to the default content pages.
    6) VERY IMPORTANT! Make sure that upload.php is moved to the top of the list.

    That’s it. It should work.

    I posted this a while back, the client was not complaining so I did not check back, but went to install another site and was hit with the problem. THANK YOU diangy IT WORKED!!

    SOrry what is IIS manager ? I’m on a Mac it sounds like its Windows app… ?!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Browse and Browse All does not work…’ is closed to new replies.