Support » Plugin: Yoast SEO » Broodkruimels – Ongeldige URL in veld ‘id’

Viewing 15 replies - 1 through 15 (of 26 total)
  • Plugin Support Priscilla Chapman

    (@priscillamc)

    Hi @mmwbadmin,

    To make sure that the errors were related to the schema output for version 16.5, can you update or use a test site to check the schema data using the Google Rich Results test?

    If the same error appears, please try the following steps to reindex the SEO data on your site:

    1. Install and activate the Yoast Test Helper plugin
    2. Go to Tools -> Yoast Test
    3. Click the “Reset indexables and migrations” button
    4. Go to SEO -> Tools and under “Optimize SEO Data” click the “Start SEO data optimization” button.

    For sites with more than 10,000 posts, we’d advise using the WP CLI command to do the indexation on the server instead of going to SEO > Tools. You can read more about this here: WP CLI – Reindex Indexables command

    Can you let us know the results?

    Thread Starter mmwbadmin

    (@mmwbadmin)

    Sorry, I don’t have an online test site.

    Plugin Support suascat_wp

    (@suascat_wp)

    @mmwbadmin

    While checking the page source of this page https://www.mmwb.nl/mannen-mv/w-x-y-z/wolf-ruben/ we have seen another (duplicate) set of schema generated, probably being added by some other plugin or theme itself. This may result in unexpected errors.

    In such case, you might want to check with your theme developer regarding the schema output so that it doesn’t interfere with the output from the Yoast SEO plugin. We have guidelines here if you want to ensure that the output from your plugin and theme will work with the Yoast SEO output without any issues — https://developer.yoast.com/features/schema/integration-guidelines.

    Please let us know if you have any other questions.

    Thread Starter mmwbadmin

    (@mmwbadmin)

    Hi,
    I add json-ld myself to indicate what the post/page is about: persons and organizations. Had no problems over the last year up to Yoast 16.4

    With 16.5 the errors show up in GSC in strings like: “{“@type”:”ListItem”,”position”:3,”name”:”G H I”,”item”:”/“}” where the / is highlighted as the culprit

    Thread Starter mmwbadmin

    (@mmwbadmin)

    Example:

    {
       "@context": "http://schema.org",
       "@type": "WebPage",
     "url": "https://www.mmwb.nl/braziliaanse-minister-van-milieu-betrokken-bij-illegale-houthandel/",
       "isPartOf":{
           "@type": "WebSite",
           "url": "https://www.mmwb.nl/"
           },
       "about":[ {
          "@type": "Person",
          "name": "Ricardo Salles",
          "gender": "http://schema.org/Male"
       },
       {
          "@type": "Person",
          "name": "Eduardo Bim",
          "gender": "http://schema.org/Male"
       }]
    }
    Plugin Support suascat_wp

    (@suascat_wp)

    @mmwbadmin

    Upon checking the given pages URL again, for example, https://www.mmwb.nl/annex/afkortingen/
    via Rich Results Test we are seeing no more structure data error. The Google Search Console error could be transitional error and should drop over time.

    Please keep monitoring the Google Search Console report and let us know if any further assistance needed.

    Thread Starter mmwbadmin

    (@mmwbadmin)

    Hi,

    Indeed, under version 16.1.1 there is no issue. I updated to 16.5 and the issue pops up again, e.g with https://www.mmwb.nl/mannen-mv/g-h-i/g-arjan/ in a Rich Result Test

    Plugin Support Michael Tina

    (@mikes41720)

    Hi @mmwbadmin

    Upon checking this URL https://www.mmwb.nl/mannen-mv/g-h-i/g-arjan/ in both Google’s RRT and SDTT, it looks like the error reported is “The value provided for id must be a valid URL.” as the idfield looks to be “/” instead of an actual URL.

    We understand you’ve modified the default Yoast SEO schema output. If you were to temporarily remove all of the modifications you’ve made and just used the default Yoast SEO schema output, could you then check if there aren’t any more errors appearing for this page on Yoast SEO v16.5 when testing it again?

    Please also understand we can’t provide support if you’ve added custom code, but we would like to refer you to our schema API to ensure that you’re implementing the changes correctly – https://developer.yoast.com/features/schema/api/

    • This reply was modified 1 year, 3 months ago by Michael Tina.

    Yoast Support – same Search Console issue on version 16.5. Here’s the offending code generated by the new plugin version:

    {“@type”:”ListItem”,”position”:3,”name”:””}]},

    This is the URL: https://www.framelessshowerdoors.com/3508/

    Can you help?

    Plugin Support Michael Tina

    (@mikes41720)

    Hi @dglick5

    We are sorry you’re having a similar issue. Please open a new request. That way it’s easier to track issues and provide assistance. Thanks!

    Done – thank you!

    Plugin Support Michael Tina

    (@mikes41720)

    Hi @mmwbadmin

    Upon checking https://www.mmwb.nl/mannen-mv/g-h-i/g-arjan/, we do see that the error of “The value provided for id must be a valid URL.” still appears for the breadcrumb schema, because the URL field in the id isn’t being populated with the absolute URL.

    Can you please try resetting our indexables in the database tables by following the steps below?
    1. Install & activate the Yoast Test Helper plugin
    2. Go to Tools > Yoast Test
    3. Locate the Yoast SEO section and click on the ‘Reset indexables tables & migrations’. After each click, the page will reload to confirm that each reset was successful. Note: this won’t actually erase your SEO data, which is also stored in WordPress’ default tables. It’ll just reset our index (custom tables) for that data.
    4. Go to SEO > Tools, and under SEO data, click the “Start SEO data optimization” button to allow Yoast to rescan your content.

    Could you then check and see if this resolves the issue?

    Thread Starter mmwbadmin

    (@mmwbadmin)

    Hi Michael,

    I followed all of your steps and I’m afraid that it hasn’t changed a thing. I’m still getting the error message.

    I added some JSON, but didn’t alter the Yoast SEO JSON: see above. It stands apart from the plugin JSON.

    There are quite some other people (still) encountering this issue. Hope it can be resolveer and time soon. Using v16.6

    Make sure the post has a Meta title and it shows up in the page source. The schema should change and you shouldn’t get the error anymore.

    That’s what I had to do. Hope it helps.

    Thread Starter mmwbadmin

    (@mmwbadmin)

    Hi,

    what should be the correct code in below example?
    In other words, what should be on the place of “item” on “position” 2 & 3?
    `{“@type”:”BreadcrumbList”,”@id”:”https://www.mmwb.nl/mannen-mv/w-x-y-z/wolf-ruben/#breadcrumb”,”itemListElement”:[{“@type”:”ListItem”,”position”:1,”name”:”Home”,”item”:”https://www.mmwb.nl/”},{“@type”:”ListItem”,”position”:2,”name”:”Mannen (m/v)”,”item”:”/”},{“@type”:”ListItem”,”position”:3,”name”:”W X Y Z”,”item”:”/”},{“@type”:”ListItem”,”position”:4,”name”:”Wolf, Ruben”}]}

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘Broodkruimels – Ongeldige URL in veld ‘id’’ is closed to new replies.