Support » Plugin: Word Filter Plus » Broken with WP 3.5

  • The core function wpdb::prepare() was changed to require 2 arguments as of WP 3.5. Until Brian Layman gets enough time to fix it, change line 141 in word-filter-plus.php from:
    $word_filter_plus_replacements = $wpdb->get_results( $wpdb->prepare( "SELECT * FROM " . $this->plugin_table_name . " ORDER BY id" ),
    to:
    $word_filter_plus_replacements = $wpdb->get_results( $wpdb->prepare( "SELECT * FROM " . $this->plugin_table_name . " ORDER BY id",$a ), ARRAY_A ) ;
    (added dummy variable $a).

    [ signature removed ]

    http://wordpress.org/extend/plugins/word-filter-plus/

  • The topic ‘Broken with WP 3.5’ is closed to new replies.