Support » Plugin: FeedWordPress » BROKEN with the WordPress 4.7 update

  • Resolved lkeels

    (@lkeels)


    Causes errors to appear on every admin page.

    FeedWordPressHTTPAuthenticator::set_auth_options() expected to be a reference, value given in /home/xxxxxxx/public_html/wp-includes/class-wp-hook.php on line 300

Viewing 15 replies - 31 through 45 (of 53 total)
  • Warning: require_once() [function.require-once]: Unable to access /membri/snapchatcodes/wp-includes/class-wp-feed-cache.php in /membri/snapchatcodes/wp-content/plugins/feedwordpress-master/feedwordpress.php on line 100

    edit: Ignore, I didn’t see the other pages of discussion.

    • This reply was modified 2 years, 11 months ago by srg.

    Confirming that. I was getting 500 server errors, on the front end and on the admin screens. Strangely, no errors were showing up in my logs. But rolling back the plugin solved the problem.

    I’m on WP 4.6.1.

    Plugin Author C. Johnson

    (@radgeek)

    Thanks for the heads-up and for the error message text, y’all.

    I just pushed out a quick patch, as version 2016.1213 of FeedWordPress. It’s available on Github, and it’s also available through the WordPress plugins repository.

    The tl;dr is that you should now be able to use FeedWordPress without trouble in versions of WordPress either before 4.7 or after 4.7, so if you were having problems with the 4.7-related warnings described earlier in this thread, or problems with the breakage from pre-4.7 versions of WordPress, as described later in this thread, this release should fix that.

    The problem is, basically, that between WP 4.6.1 and WP 4.7, the WordPress dev team decided to reorganize how they store the code modules that implement SimplePie and a number of auxiliary classes related to using SimplePie within the WordPress environment. FeedWordPress depends on SimplePie to fetch and parse feeds. So if FeedWordPress attempts to load in the needed modules using the old pre-WP 4.7 scheme, in 4.7 you’ll get a snippy PHP warning from WordPress about loading deprecated modules. OTOH, if it attempts to load in the needed modules using the new post-4.7 scheme, then in versions of WordPress before 4.7 you’ll get a fatal error, because the needed code is in a different file. In any case: in the interest of balancing both backward- and forward-compatibility, the latest release now runs through the classes that it needs to load, and tests whether or not the 4.7-and-later modules for those classes exist. If so, it loads them up. If not, it falls back on loading the now-deprecated module that versions prior to 4.7 have. In either case, it should more or less smoothly load up the code it needs to load up without pitching a fit in either version.

    If you have any questions, let me know. If you are still having compatibility problems with the latest release, let me know — but if the problem you’re seeing is different from the problems described in this thread, please consider opening a separate thread on the forum here or contacting me via email. If after a couple of days of folks checking it out, this release seems to have fixed all of the problems described in the thread here, I’ll go ahead and mark this issue as closed.

    Thanks all for the heads-up on these compatibility issues.

    Works on 4.6.1. Thanks!

    hello all,

    well, it doesn’t work on my WordPress.

    FeedWordPress STILL BROKEN on my site.
    I change WP version using:
    WP downgrade | specific core version plugin

    WP 4.5.4
    WP 4.6.1
    WP 4.7

    all says this:

    Plugin could not be activated because it triggered a fatal error.

    using these FWP versions:

    2016.1213
    2016.1211
    2016.0420

    different trys same fatal error on activation stage.

    please, any clues?

    thanks

    Plugin Author C. Johnson

    (@radgeek)

    I’m sorry to hear you’re having this problem, @yoshuahaxo . When you try to activate the plugin, does WordPress give you the text of the PHP fatal error that occurs? If so, could you copy and paste the error message that you are getting, either in a post on this forum or via e-mail to feedback+feedwordpress@radgeek.com ? If I can take a closer look at what’s going on I might be able to help you troubleshoot the problem.

    hello Radgeek,

    thank for your fast replay, surely this issue will be resolved, but my backend plugin screen don’t show any other info after try to activate FWP, just this:

    “Plugin could not be activated because it triggered a fatal error”

    i don’t know where else to look for error messages or how to force WP to show up aditional info about a failed plugin activation task.

    i’ll gonna be more than happy if you or somebody else send any hint about how to view this error message.

    thanks for helping,

    Haxo

    Plugin Author C. Johnson

    (@radgeek)

    O.K., do you have access to your web server or PHP error log? If so you could look there for error messages just after attempting to activate the plugin. Alternatively, if you’re not sure where to look, could you contact me off-list by e-mail at feedback+feedwordpress@radgeek.com ? I can take a quick look and let you know whether there is a simple fix for the problem you’re having or whether you’re likely to need a more extended troubleshooting session.

    My site is broken as well. Hopefully they will pay attention & fix it soon.

    Thanks, Radgeek!

    Thank you Radgeek. It’s working again.

    Same problem
    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘vc_remove_frontend_links’ not found or invalid function name in /home2//public_html/wp-includes/class-wp-hook.php on line 299

    • This reply was modified 2 years, 10 months ago by dolszowy.

    ……… error class-wp-hook.php on line 298
    It’s crazy…but when i deactivate NextGEN Gallery all problems disappeared
    –†erhaps other plugins also cause the same error over WP 4.7.1 version!!! We will check !!!

    • This reply was modified 2 years, 9 months ago by local1970.
    • This reply was modified 2 years, 9 months ago by local1970.
    • This reply was modified 2 years, 9 months ago by local1970.

    Same error – but I don’t have and never have had this plugin!

Viewing 15 replies - 31 through 45 (of 53 total)
  • The topic ‘BROKEN with the WordPress 4.7 update’ is closed to new replies.