Support » Plugin: FeedWordPress » BROKEN with the WordPress 4.7 update

  • Resolved lkeels

    (@lkeels)


    Causes errors to appear on every admin page.

    FeedWordPressHTTPAuthenticator::set_auth_options() expected to be a reference, value given in /home/xxxxxxx/public_html/wp-includes/class-wp-hook.php on line 300

Viewing 15 replies - 16 through 30 (of 53 total)
  • Tony Brocklebank

    (@tony-brocklebank)

    I’m having the same problem but can someone explain with the fix outlined will the problem recur when another update comes along?

    froomkin

    (@froomkin)

    I emailed the author, he says he plans to start work on a fix this weekend — after his exams. Which seems like sensible priorities.

    Gwyneth Llewelyn

    (@gwynethllewelyn)

    Just to confirm that removing the ampersand will work nicely, even under nginx/php7.0-fpm.

    Great to know that the author is still around, this is one of the most complex and sophisticated plugins I’ve been using for years (excepting perhaps all those front-page editors…), and one that has been pretty resilient when dealing with so many changes, both from WP and from PHP…

    WPChina

    (@wordpresschina)

    Same problem here. Will implement the fix 🙂

    Tony Brocklebank

    (@tony-brocklebank)

    Thanks folks, just realised while I thought the error was only appearing on the dashboard it was also appearing right at the bottom of most pages, so I’ve implemented the fix and all seems fine!

    MoonGunner

    (@moongunner)

    This worked perfectly!

    Removing the & from &$handle in line 153 fixed everything for me.

    You can find the document here…

    /wp-content/plugins/feedwordpress/feedwordpresshttpauthenticator.class.php

    Thanks so much!

    lexwahl

    (@lexwahl)

    The fix by garymarkfuller worked great for me. Thanks!

    cogdog

    (@cogdog)

    Now this fix by @garymarkfuller having some negative effects…

    It generates a fatal error on the other plugin from the FeedWordPress I use for getting images from feeds https://github.com/radgeek/FWP—SIC–Em and the FWP Add Attribution plugin https://github.com/radgeek/FWP—Add-Attribution fails fatally to looking for the is_synidicated() function

    Plugin Author C. Johnson

    (@radgeek)

    Hey all, so, I’m working on a fix for the problem this weekend. I need to do some testing and will then push all needed fixes out with a new official release on the WordPress plugins repository.

    It looks like the issue is that WP 4.7 introduced a new call to the http_api_curl hook, which FeedWordPress attaches itself to in order to implemenet some advanced options for HTTP authentication when retrieving feeds. That’d be fine but the handling of referencing parameters is incosnistent between the two calls to that hook, so in one case the relevant method in one of FeedWordPress’s classses is being called without the parameter being referenced as it expected it to be. So I made a small tweak very similar to @garymarkfuller and confirmed that it seemed to solve the issue on at least one site that was having this issue in the wild. While I was there I also removed a deprecated-file warning that also came along with the WP 4.7 upgrade. If you feel comfortable grabbing a development version from Github and testing it out, the fixes appear on the master branch at http://github.com/radgeek/feedwordpress/

    If you install the development version and successfully install it, let me know if it solves the problem for you. The fix makes a minor change that affects a function that FWP uses to set HTTP authentication options; so if you use HTTP Authentication (especially if you use HTTP Digest Authentication) to retrieve any of those feeds, you should make sure to double-check those feeds and confirm that FWP can still successfully fetch them without any negative side-effects. If you happen to have a set-up that allows you easily to test this with feeds you retrieve using HTTP Authentication, please feel free to get in touch with me here or via e-mail at <feedback+feedwordpress@radgeek.com> to let me know what you’re seeing; it’d be very helpful in allowing me to confirm that the fix works as expected.

    HOWEVER, if as @cogdog suggests there are negative side-effects for other related add-ons like SIC ‘Em or Add Attribution, you may want to be cautious about proceeding with the test if you use either of those problems. I’ll be testing the other add-ons this weekend also and hopefully we can get these issues ironed out soon.

    @cogdog , could you send me the text of the fatal errors you’re seeing from the other plugins, either here or via e-mail? I’ll be able to take a look at these later this afternoon.

    • This reply was modified 3 years ago by C. Johnson.
    cogdog

    (@cogdog)

    Thanks for the update @radgeek — I cannot seem to reproduce the errors again (using the fix by @danyork).

    My copy of FWP–Sic–EM was out of date, and it seems to be fine with the updated one. The error on FWP-Add-Attribution was after I had disabled FWP–Add-Attribution (error for call to is_syndicated() function). I am continuing to test on a few other non critical sites.

    rolfkrueger

    (@rolfkrueger)

    ATTENTION! New Version breaks complete site when < WP 4.7

    In my case, it’s 4.6.1, @radgeek

    Plugin Author C. Johnson

    (@radgeek)

    @roflkrueger could you drop me a line either here or via email with some details on the breakage that you see with 4.6.1? Are you getting a PHP fatal error, or some other problem? If the former, what’s the text of the error? If the latter, what are you seeing on your end? I’m out of the office right now but should be able to check this out in more detail when I get back to my laptop, so any details you can give me on the situation will be helpful.

    msitarzewski

    (@msitarzewski)

    @radgeek – here’s the error in PHP:

    [11-Dec-2016 18:32:57 UTC] PHP Warning: require_once(/var/www/webroot/wp/wp-includes/class-wp-feed-cache.php): failed to open stream: No such file or directory in /var/www/webroot/wp-content/plugins/feedwordpress/feedwordpress.php on line 100
    [11-Dec-2016 18:32:57 UTC] PHP Fatal error: require_once(): Failed opening required ‘/var/www/webroot/wp/wp-includes/class-wp-feed-cache.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /var/www/webroot/wp-content/plugins/feedwordpress/feedwordpress.php on line 100

    I’m on WordPress 4.5.4.

    class-wp-feed-cache.php is new to 4.7

    SuzuKube

    (@suzukube)

    Same error here :
    Warning: require_once(/home/gamepushle/www/wp-includes/class-wp-feed-cache.php): failed to open stream: No such file or directory in /home/gamepushle/www/wp-content/plugins/feedwordpress/feedwordpress.php on line 100

    Fatal error: require_once(): Failed opening required ‘/home/gamepushle/www/wp-includes/class-wp-feed-cache.php’ (include_path=’.:/usr/local/php5.4/lib/php’) in /home/gamepushle/www/wp-content/plugins/feedwordpress/feedwordpress.php on line 100

    But I’m upgrading to wordpress 7, so it will be ok :p !

    rolfkrueger

    (@rolfkrueger)

    @radgeek: It’s a 500 internal server error. Upon restoring the former plugin version, everything is working again.

    I use PHP 7.0.11 on Apache.

Viewing 15 replies - 16 through 30 (of 53 total)
  • The topic ‘BROKEN with the WordPress 4.7 update’ is closed to new replies.