Support » Plugin: Advanced Custom Fields: Tag It Field » Broken with ACF Pro V. 5.6.0+

  • Wanting to let the developer know that as of Advanced Custom Fields PRO version 5.6.0, ACF now uses Select2 JS v4.

    This update breaks the functionality of the Tag It fields because of changes in how Select2 JS now works.

    Seeing how this plugin hasn’t been updated in over a year now, I’m wondering if either I should modify the plugin to work with the new changes, or if it will be updated by the author?

    ACF PRO Changelog https://www.advancedcustomfields.com/changelog/
    Select2 V4 new usage https://select2.github.io/examples.html
    Select2 V3.x.x usage http://select2.github.io/select2/ (note the differences)

    For anyone else who may stumble upon this thread in the future, the issue is ends up being that Select2 has changed to work with only select boxes and not input fields (as it currently is), as well as requiring data attributes.

    It’s a somewhat tricky problem especially in making sure that pre-existing data displays properly after switching the field from input to select. I’ve not yet solved the problem in the plugin code at this time, hoping the author can tackle that 😉

    In the meantime, I’ve downgraded ACF PRO to version 5.5.14 which is the most recent version of ACF that is compatible with this plugin.

Viewing 1 replies (of 1 total)
  • I wish this field type was built-in to ACF PRO. Could really use a field to select tags that have been entered into wordpress.

    At a later date, I may try to modify the plugin to work with the tags in wordpress. If i make some progress i will post my code to github.

    • This reply was modified 2 years, 5 months ago by robbiegod.
Viewing 1 replies (of 1 total)
  • The topic ‘Broken with ACF Pro V. 5.6.0+’ is closed to new replies.