Support » Plugin: Adaptive Images for WordPress » Broken when switched site to HTTPS

  • Does this plugin work with HTTPS at all? I had to deactivate this plugin to get my images to show on the site, and anytime I try to re-enable it, it breaks again. Is there a step I’m missing, or are the two not compatible?

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Takis Bouyouris

    (@nevma)

    Hello, there,

    Well, actually the plugin itself is agnostic of whether your website is using HTTPS or not! However, it might get confused when using both HTTP and HTTPS or when you are in the middle of a transition from HTTP to HTTPS, or vice versa.

    Could you please check the “WordPress Address (URL)” and the “Site Address (URL)” in your WordPress “General settings” page? Do they contain “http” or “https”? It is very probable that they still mention “http”. If that is indeed the case, then you should make sure that you change this -and all of your websites urls along with it- to “https”, so that the transition to HTTPS is complete and that no code within your website will be confused by such a setting.

    (You might need to save your Adaptive Images settings anew after this, too!)

    Let me know if this worked for you and if there is anything else I can do!

    Cheers,
    Takis

    It’s not my first HTTPS rodeo, those settings are the first thing I change. I also use velvet update URL to update all the image URLs to reflect the HTTPS as well.

    I was also not sure why this plugin would be affected by HTTPS, all I know is now when I activate it, my slider disappears, gallery images won’t load, and a bunch of funky stuff happens on the page. I just tried again today after it being HTTPS over the long weekend, and it does the same thing.

    Plugin Author Takis Bouyouris

    (@nevma)

    Hello, again,

    As I said before, the plugin does not care whether you use HTTP or HTTPS, but it does get affected when a transition from HTTP to HTTPS happens. The reason is that the plugin must translate images from urls to local path. And, of course, the image urls are affected by HTTP/HTTPS.

    Now if the plugin was working OK so far then what you need to do is a) make sure your have HTTPS set in your website urls, in your WordPress “General settings”, like this http://prntscr.com/ext1n8/ and b) save the Adaptive Images settings anew, so that the plugin settings are aware of the website urls change.

    Are you certain that you have followed these two steps? All our tests, for all different setups, have shown that this should work, but I would really like to find out whether there is some other case which we have not predicted yet.

    Also, if it is not too much trouble, could you please momentarily activate the plugin and send me the results of the “Print debug” and “Print diagnostics” buttons in the plugin settings page?

    Cheers,
    Takis

    Doing A & B mentioned above didn’t do anything, however I found clearing the image cache sorted out the issues I was having. If you still need it I’ll paste the debug info here (but I’ll be changing the URL of the site)

    —-

    Debug info

    ✔ PHP GD library is installed.

    ✔ Image cache directory has been created.

    /home/example/public_html/wp-content/cache/adaptive-images => drwxr-xr-x

    ✔ Installation .htaccess file is setup OK.

    /home/example/public_html/.htaccess => -rw-r–r–

    ❖ Adaptive images settings dump:

    array(14) {
    [“resolutions”]=>
    array(3) {
    [0]=>
    int(1024)
    [1]=>
    int(768)
    [2]=>
    int(480)
    }
    [“cache-directory”]=>
    string(21) “cache/adaptive-images”
    [“watched-directories”]=>
    array(2) {
    [0]=>
    string(18) “wp-content/uploads”
    [1]=>
    string(24) “wp-content/themes/images”
    }
    [“jpeg-quality”]=>
    int(75)
    [“sharpen-images”]=>
    bool(true)
    [“watch-cache”]=>
    bool(true)
    [“browser-cache”]=>
    float(180)
    [“landscape”]=>
    bool(false)
    [“hidpi”]=>
    bool(false)
    [“cdn-support”]=>
    bool(false)
    [“version”]=>
    string(6) “0.6.62”
    [“sanitized”]=>
    bool(true)
    [“wp-content-dir”]=>
    string(47) “/home/example/public_html/wp-content”
    [“wp-content-url”]=>
    string(44) “https://www.example.ca/wp-content”
    }

    ——

    System information

    Web Server

    Apache/2.4.6
    Document Root

    /home/example/public_html
    PHP

    5.6.25
    PHP Time Limit

    30
    PHP Memory Limit

    256M
    PHP Post Max Size

    8M
    PHP Upload Max Size

    2M
    PHP Max Input Vars

    1000
    PHP Display Errors

    No
    PHP Error Log

    MySQL

    5.5.52-MariaDB
    MySQL Ext/mysqli

    Yes
    MySQL Table Prefix

    xxx_
    MySQL DB Charset

    utf8
    WP

    4.7.3
    WP Multisite

    No
    WP Debug Mode

    No
    WP Site url

    https://www.example.ca
    WP WP Home url

    https://www.example.ca
    WP Permalinks

    /%postname%/
    WP home path

    /home/example/public_html/
    WP content dir

    /home/example/public_html/wp-content
    WP plugin dir

    /home/example/public_html/wp-content/plugins
    WP content url

    https://www.example.ca/wp-content
    WP plugin url

    https://www.example.ca/wp-content/plugins
    WP Locale

    en_US
    WP Memory Limit

    40M
    WP Max Upload Size

    2mb
    WP Active plugins

    404 to 301 v.2.3.3 by Joel James
    Accelerated Mobile Pages v.0.9.47.2 by Ahmed Kaludi, Mohammed Kaludi
    Adaptive Images for WordPress v.0.6.62 by Nevma
    All in one Favicon v.4.6 by Arne Franken
    AMP v.0.4.2 by Automattic
    Autoptimize v.2.1.0 by Frank Goossens (futtta)
    BackupBuddy v.7.3.1.2 by iThemes
    Block Bad Queries (BBQ) v.20161114 by Jeff Starr
    Column Shortcodes v.0.6.9 by Codepress
    Contact Form DB v.2.10.28 by Michael Simpson
    Contact Form 7 v.4.7 by Takayuki Miyoshi
    Duplicate Post v.3.2 by Enrico Battocchi
    Enable Media Replace v.3.0.6 by Måns Jonasson
    MailChimp v.1.5.7 by MailChimp
    Mini Loops v.1.3.1 by Kailey Lampert
    Meta Slider v.3.5 by Matcha Labs
    No Comments v.1.1.6 by Steven Fernandez
    PHP Text Widget v.1.0.8 by Stefano Lissa
    Q and A FAQ and Knowledge Base for WordPress v.1.0.6.2 by Raygun
    Really Simple CAPTCHA v.1.9 by Takayuki Miyoshi
    Responsive Menu v.3.0.18 by Peter Featherstone
    Speed Booster Pack v.3.0 by Tiguan
    Stealth Login Page v.4.0.0 by Jesse Petersen
    Sucuri Security – Auditing, Malware Scanner and Hardening v.1.8.3 by Sucuri, Inc
    Velvet Blues Update URLs v.3.2.7 by VelvetBlues.com
    W3 Total Cache v.0.9.5.2 by Frederick Townes
    Galleries by Angie Makes v.1.56 by Chris Baldelomar
    White Label CMS v.1.6.1 by http://www.videousermanuals.com
    Wordfence Security v.6.3.6 by Wordfence
    Yoast SEO v.4.6 by Team Yoast
    WP Editor Widget v.0.5.5 by David Mårtensson, Odd Alice
    WP Force SSL v.1.3 by Kostas Vrouvas
    WP Smush v.2.6.2 by WPMU DEV
    WPS Hide Login v.1.1.7 by Remy Perona for WPServeur

    WP MU plugins

    Plugin Author Takis Bouyouris

    (@nevma)

    Hello, again,

    Thanks for the debug info. It all seems as expected, I cannot see out of the ordinary there.

    I am glad that clearing the image cache worked for you, although I cannot connect it to the initial problem. I will keep a note of it for other users in the future.

    Let me know if there is anything else I can do for you.

    Cheers,
    Takis

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Broken when switched site to HTTPS’ is closed to new replies.