Support » Plugin: Acunetix WP Security » Broken update 4.0.1

  • Resolved Marcos



    I’ve been using “wp-security-scan” for a long time and it’s been working very well.
    My plugin’s version was 3.1.0.

    So, today there was an update to version 4.0.1.

    I’ve done the update and with this new version activated I can’t see it in menu anymore (it’s disappeared from there).
    I have no access to settings, scan, monitoring view or anything else.

    The plugin “wp-security-scan” apppears activated in the plugins list but doesn’t have ‘settings‘ link, only ‘deactivate‘ link.

    Any ideas???

Viewing 15 replies - 1 through 15 (of 17 total)
  • Same here. I can’t find the settings.

    I think i found the issue (this worked for me). Goto plugins, you will see 2 installations of the same plugin (probable at the top). Deactivate the old one and bingo it will work.



    I’ve already done that but not worked for me.

    I’ve also tried to exclude the whole folder and uploaded only the new version 4.0.1.
    After activating everything remains the same way: vanished into thin air!

    The problem is that the plugin changed the name during the update – it HAS to be deactivated, then activated again.



    I’ve already done that (deactivated and re-activated) but the problem persists.

    Deactivating & re-activating the plugin worked for me. Shows as “WP Security” in the bottom group in the site admin menu.



    Am I the only unlucky one here?

    Could it be a conflict with other plugin?

    Is there a way to erase all traces of this plugin, including inside the database, and restart a clean installation of “wp-security-scan“?
    Could this procedure help or not?

    I don’t no what to do.

    Any ideas?

    I’m having the same issue – nothing is showing in the admin menus. I’ve tried the suggestions above and even did a clean install. Nothing.

    Could be worse – I first installed the plugin now, never used before and I’m having the same issue, so it’s probably not related (also from our point of view) to the change in name.

    What worked for me is the following:

    1. Deactivate your current version of WP Security Scan.

    2. Physically remove the “wp-security-scan” folder from your “plugins” directory.

    3. Download the Acunetix WP Security 4.0.1 plugin from the WordPress Plugins website.

    4. Install the plugin in the usual manner in the “plugins” folder.

    5. Activate the plugin. Please note that on your blog’s “Plugins” page, the plugin is now called “Acunetix WP Security”.

    The only problem I have encountered thus far with 4.0.1 is that for some reason, on the Scanner page, it is not recognizing the “wp-config.php” It is minor, however, because I use another program to set the permissions on the files and folders which constitute my blog.



    Hi WordWeaver777

    I’ve already done all of these procedures but the problem persists.

    Could be some problem connected to the database? Any residue left behind after uninstalling the plugin?

    The developer could give us some ideas, ok?

    People here with the same problem that I have could vote in the plugin as broken to force the developer to give us some solution.



    Some minutes ago I updated my WP blog.

    Before doing this I had disabled all plugins.
    After updating WP I was re-activating all plugins one by one and started by “WP Security Scan”.

    Even when only this plugin was enabled it did NOT appear in the menu.
    After activating all other plugins the “WSS” still does not appear on the menu.

    So, I’ve disabled “Acunetix” and deleted its folder. :'(

    I’ll wait for a new working version.

    Plugin Author Acunetix


    Hello everyone

    We are very sorry to hear about your issues 🙁 The latest version of this plugin has come with a completely changed core and a new name, and issues like this might occur when updating from an older version…

    Please check my answer in the following thread for a solution to this issue.

    We are very sorry for the inconvenience




    Hi ‘Acunetix’.

    Thanks for your answer and suggestions.
    I’ve followed and done all of them ( but the problem persists.
    Your plugin doesn’t appear in the menu anymore.

    If this problem is not easy to be solved or it can take more time to be solved you could put a “Settings” link below the name of the plugin in plugin’s list.
    Is it a good idea? Is it possible? Does it function so?

    I’ve deactivated the plugin and deleted its folder.
    I’ll wait for a new version.


    I’ve had problems on 3 of about 15 sites.

    One problem site was fixed by deleting the plugin, deactivating all other plugins, downloading the and activating the plugin, and then activating all the other plugins.

    This process did not fix 2 of my sites, and I am unable to use the WP Security plugin.

    I can’t find a common factor — different themes (both used by other successfully updated sites, different hosting companies,and any plugins they share are also shared by successfully updated sites.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Broken update 4.0.1’ is closed to new replies.