Support » Theme: OceanWP » Broken theme after SSL (CSS?)

  • Resolved kardac

    (@kardac)


    We are preparing to change our site to SSL and have therefore used Elementor function to change all urls from http to https. We have installed Really Simple SSL (free) but not activated it.

    AFter that it seems that our OceanWP is broken, we can not longer reach the CSS page or open the Theme settings.

    What I´ve done so far:
    Tried switching to another theme (twentytwenty).
    – Now CSS and settings works as it should

    Deleted OceanWP and reinstalled
    – No change to the better

    Uploaded an fresh zip version of OceanWP with sftp and renamed it oceanwp2. Then i switched to this version in Themes
    – No change to the better

    • This topic was modified 1 month, 1 week ago by kardac.
    • This topic was modified 1 month ago by kardac.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Kyle Finazzo

    (@kylefinazzo)

    The problem is not (Ocean WP). Some plugins, such as “Really Simple SSL” upload excessive files in the database, or in the file (.htaccess)

    When the page restarts, the theme stops working and you can have serious problems. The only thing to do is to guess which plugin made the site stop working, and never install it again.

    However … With a recovery mode of your site, you would have solved the problem and could have re-entered again.

    Watch out for plugins!

    Abhishek

    (@abhikr781)

    Hi,

    Please go to Theme Panel > Scripts & Styles, from here make sure all files should be enabled and click on the save button a couple of times. And check.

    If not resolved, share the snapshot and page URL to inspect the issue.

    kardac

    (@kardac)

    I solved it.

    1. Changed theme to TwentyTwenty
    2. Disabled all OceanWP extra plugins (noticed that I had the old OCeanWP Floating Header plugin which havent been updated in a while and is not an official plugin from the makers of OceanWP.
    3. Activated Really Simple SSL
    4. Switched back to OceanWP
    Now i can enter the CSS settings. I manually edited all http URLs to https.

    Everything works as a charm.
    I suspect the problem was OceanWP Header Plugin, but i cannot be sure and I dont have the spare time to reload a backup and test 🙂

    Thank you for all replys!

    Abhishek

    (@abhikr781)

    Thank you for sharing the solution with us and Glad to hear that the issue has been fixed!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.