Support » Plugin: Contact Form By Mega Forms - Drag and Drop Form Builder » Broken submit on some browsers.

  • Resolved akwiatek

    (@akwiatek)


    Hi, there is some weird issue with submitting forms which seems to be totally random. On Brave and Chrome everything works just fine, but on Firefox and Edge when I click submit there’s this quick animation and ajax return response as shown below:

    duration: “0.002”
    fail: true
    message: “<span class=\”mform_error_msg\”>Your session has expired, please refresh the page and try again.</span>”
    scrollTop: true
    success: true

    In every browser I was sending exact same options and text so I don’t it’s the matter of content.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter akwiatek

    (@akwiatek)

    I just checked on my coworker computer – for him it doesn’t work in any browser chrome included. Strange.

    Plugin Author Ali Khallad

    (@alikhallad)

    Hello, thanks for reporting this!

    May I ask where is your website hosted?

    Did you have the issue after the update? or was it an old issue?

    The error is caused when the session id is found in the cookies, that could happen when there is some special caching implemented on the server. The session id is used for additional security, but it’s not absolutly necessary and can be disabled. However, it’s better to fix than disable if that’s possible.

    Thanks

    Thread Starter akwiatek

    (@akwiatek)

    My website is hosted at one of my local providers in Poland so it won’t give you much info. But I followed the lead you gave me – we are using WPRocket for cache management so I disabled there option for user caching – since we don’t really have users as its company website. Seems that it worked for me – on my computer everything works fine now but I have to check on other devices. I’ll update you later if problem was resolved 🙂

    Plugin Author Ali Khallad

    (@alikhallad)

    That’s perfect.

    Can you please test something for me. Restore WPRocket options and add this to your wp-config.php file

    define("MF_SESSION_NAME", "wordpress_mf");

    This will change the session cookie name so that it starts with “wordpress_”. If WPRocket is excluding cookies starting with “wordpress_” by default, I might need to change the default cookie name to account for this and avoid the need for special configuration.

    Can you please test and let me know if the issue is gone?

    Thanks,
    Ali

    Plugin Author Ali Khallad

    (@alikhallad)

    Hello again, I just published a new update where I replaced the cookie prefix from “mf” to “wordpress_mf”, this should help with caching plugins that are excluding the “wordpress_” prefix from being cached.

    I’ll go ahead and mark this as resolved. Feel free to open another ticket if you run into this issue again.

    Thanks,
    Ali

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Broken submit on some browsers.’ is closed to new replies.