Support » Plugin: The Events Calendar » Broken Sitemap-Links "tribe_events"

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thread Starter LeftHandedCat

    (@lefthandedcat)

    Edit: Links are provided with an *additional* backslash when a simple dash (-) is used in the URL. So there are *no missing* slashes as mentioned above. See pics in my first post: 3 backslashes in every Event-URL, that should not be there.

    Hi Axel.

    Thanks for the screenshots.

    It looks like you’re using Yoast SEO plugin for your XML Sitemaps.

    I tested with it and couldn’t reproduce your issue.

    Please Test For Conflicts and see if that helps clear things up (don’t forget to re-save your WordPress Permalinks throughout such testing).

    Hey LeftHandedCat,

    I am having the same issue. Any updates?

    Thanks
    Joel

    Thread Starter LeftHandedCat

    (@lefthandedcat)

    Hi Clifford & danowitz,

    thanks for your reply! I’ve tested a lot for conflicts, but I wasnt able to return to a no-fault condition. 🙁 I think there must be an error somewhere in the plugin code or a conflict between events-calendar and yoast.

    Any other suggestions Clifford?

    Hey danowitz,

    which Theme do you use? I’m using (Theme Maha) Curated. Do you also use Yoast SEO for your sitemap?

    Best regards
    Axel

    Hello,

    If you’re currently using a “-” (example, “upcoming-events”) in your Events URL slug found under Events > General, you could potentially be experiencing a know bug.

    Does your Events URL slug include the “-” character?

    Thanks for posting and for choosing TEC 🙂

    Thread Starter LeftHandedCat

    (@lefthandedcat)

    Hi joinfof,

    thanks for your reply! At first: good to hear that the bug is already known 🙂 unfortunately, I use dashes in the URL-Slug 🙁

    As you can see in my sitemap, the calendar itself is correctly listed in the sitemap, but all events-links are broken:

    http://screencast.com/t/2YJ3QhwE

    Do you working on a solution and will there be a fix in the next plugin update?

    All the best
    Axel

    Hello and welcome back,

    I wish I did have a concrete answer for you on when a solution will be released, but I do not have any additional information at this time. Hang tight and stay tuned to theeventscalendar.com/blog and your WP admin for update information.

    Thread Starter LeftHandedCat

    (@lefthandedcat)

    Since the last update the whole plugin is down 🙁 (see URL Redirect Thread / all calendar links broken). I have looked into the plugin directory, and it is not surprising that there are currently so many errors: The plugin includes hundreds of files and an enormous amount of code. Can you purify it? It certainly makes sense to outsource some more functions in Addons / in your Addon System. In particular, those which are used by only a few users to cleanup the codebase. I know, this can be a challenging task in the first place, but after that, you may find errors much easier and they will only affect those users who have installed that special addon.

    After some tests, I can say that the plugin slows down the loading time of our site by more than 0.5 seconds! (vServer, SSD, dedicated Intel Xeon E5-26xxV3 Cores, DDR4 RAM). Half a second, just to have a calendar a and few event pages is a lot of time.

    Best regards
    Axel

    Hey Axel,

    Thanks for the constructive criticism. We are always looking for ways to improve our plugin, from the code, performance, look and feel, etc. Stay tuned for a maintenance release and hopefully we’ll get a fix addressed ASAP. Have a great week and thanks for choosing TEC 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Broken Sitemap-Links "tribe_events"’ is closed to new replies.