• Resolved rwonnink

    (@rwonnink)


    Hi,

    I was using paid weglot translation plugin but after few problems I have searched for other plugins. When testing your plugin, the plugin breaks my website after a while for already the second time. It gives me a ‘problem loading page’ error with the message: `Unable to connect

    Firefox can’t establish a connection to the server at residenceplatform.com.

    The site could be temporarily unavailable or too busy. Try again in a few moments.
    If you are unable to load any pages, check your computer’s network connection.
    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.`

    If this cant’ be fixed, this plugin won’t be an option for me and I am not thinking about upgrading to the paid version.

    Please let me know if you can help me. For your information: I have disables my speed plugins.

    Robert

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 17 total)
  • Thread Starter rwonnink

    (@rwonnink)

    Additional info:

    Strange thing is that it seems that when the site breaks, this is related to the internet connection where it did break on. When I check my website on my phone or when I make a hotspot and check my website again on my laptop, it is not broken. When I disable hotspot and use my wifi connection, it is still broken.. After a while using hotspot the site breaks again.

    • This reply was modified 1 year ago by rwonnink.
    Plugin Support Dragos

    (@dragosvrejiu)

    Hello,

    Thank you for reaching out to us!

    I have accessed your website and tried switching the language but didn’t come across the mentioned error.

    If the problem returns, please run a conflict test:

    ​​*Briefly* disable all other plugins and enable the default Twenty Twenty theme. Please also disable all add-ons. If this fixes the problem, enable everything one by one, checking each time to see when the problem returns.

    Please let us know when you find the conflict so that we can take a look and see what we can do about it.

    Best regards,

    Thread Starter rwonnink

    (@rwonnink)

    Hi,

    As I said it breaks the website for only a temporary time (more or less 20/25min) and after the break it works again. But this goes over and over again. In this way it is impossible to run a conflict test because I don’t know when the beaks occurs and when the website is broken I can’t go into wordpress backend.

    Robert

    Thread Starter rwonnink

    (@rwonnink)

    Almost a week ago and still no reply?

    Plugin Support Dragos

    (@dragosvrejiu)

    Hello Robert,

    Sorry for the late reply.

    This problem doesn’t look like it’s caused by our plugin and we haven’t encountered it before. We can’t debug it, as there are no errors that we can follow. We also can’t replicate it on clean instances in order to investigate the cause thoroughly.

    Here is an article that might help you: https://support.mozilla.org/ro/questions/1056868

    Also, you can try connecting through another internet connection and computer. Maybe it’s strictly related to Firefox, so try another browser as well.

    With the best regards,

    Thread Starter rwonnink

    (@rwonnink)

    This is not related to Firefox because I also tested with Safari and Chrome and after a few minutes of clicking around my site it also gives me the message ‘This site can’t be reachedresidenceplatform.com refused to connect’.

    You can test this for me by going to my website, choose another language and click around some pages for more or less 5minutes (could be a bit more or less). After a while the site will not be reachable and gives you a sort of message I wrote before. Please try this. I am using the paid version but if this is not going to work I am forced to ask for a refund and to use another plugin.

    Plugin Author Cristian Antohe

    (@sareiodata)

    If you’re using the paid version please contact us via https://translatepress.com/support/ , not the free forum.

    Also, the error you mention has nothing to do with your website or the server. It’s a networking error, not a PHP error.

    When this happens again: Go to START -> and in search field type CMD and press enter. After black window shows up type in ping google.com and see if it responds. If it doesn’t then DNS probably is not working or is not set correctly. Or your internet simply drops your connection.

    ” When I check my website on my phone or when I make a hotspot and check my website again on my laptop, it is not broken. When I disable hotspot and use my wifi connection, it is still broken” -> This signifies your internet is down, not that the website is down.

    Plugin Author Cristian Antohe

    (@sareiodata)

    Hello,

    So I was navigating your site and I did get the same error message. So your local internet connection is not causing this.

    However, it could be your server is either underpowered or has a poor network connection.

    Most likely you get a 500 error, but instead of throwing that error, the server simply fails silently that could look like a Networking issue.

    The 500 error (or sometimes a white page or "The site is experiencing technical difficulties.") is a very general server error.
    
    One of the first web search results says that "The 500 Internal Server Error is a very general HTTP status code that means something has gone wrong on the web site's server but the server could not be more specific on what the exact problem is."​​
    
    To debug this further, please follow these steps:
    ​​
    1. Ask your host to identify this specific error and/or for the PHP error log.
    2. Try and increase your WordPress memory limit: https://docs.woocommerce.com/document/increasing-the-wordpress-memory-limit/
    3. set WP_DEBUG to true in wp_config.php file: https://codex.wordpress.org/WP_DEBUG and try again. See if you get any errors.
    ​4. Check if you have duplicate entries in your *trp_* tables from the database. If you do, you can use the Remove duplicate rows option from TP Settings --> Advanced tab to clear them.
    5. Try to do a conflict test (ideally in a staging environment):
    ​​*Briefly* disable all other plugins and enable the default Twenty Twenty theme. Please also disable all add-ons. If this fixes the problem, as it probably will, enable everything one by one, checking each time to see when the problem returns.
    Please let us know when you find the conflict so that we can take a look and see what we can do about it.
    Thread Starter rwonnink

    (@rwonnink)

    Hi Christian,

    I have sent this to my hosting provider and they came with the following reply:

    The reason you get a 500 message is because your IP address is (temporarily) blocked.  I have visited your website myself and when I click through your website I make 84 post requests within 3 seconds.  The server thinks this is suspicious, making a post request so often is something that spammers do by frequently leaving comments or abusing a form.  This way, an IP address that does a lot of mailing actions is blocked within a short period of time.
    
     You should ask the makers of the plugin if it is normal for so many post requests to be made.  You can show the access log to the plugin makers, then they see that this is frequently called:
    
     "POST /wp-content/plugins/translatepress-multilingual/includes/trp-ajax.php HTTP / 1.1"
    
     You will find the access log in your Control Panel under Web hosting> Logs.
    Plugin Author Cristian Antohe

    (@sareiodata)

    Hi!

    That makes sense. That’s the javascript translation engine. Basically we’re listening for javascript changes on your website and if we detect any strings that we’re changed, we try to translate them.

    Please go to `TranslatePress -> Settings -> Advanced -> Disable dynamic translation and check that setting. Then check again.

    Thread Starter rwonnink

    (@rwonnink)

    Hi,

    This seems to work but the property pins on the map are now showing strange. See my website: https://residenceplatform.com/

    The below part disappeared and the numbers are smaller and not aligned in the middle.

    Robert

    Plugin Author Cristian Antohe

    (@sareiodata)

    Hi,

    I can see some pins that are misalligned, however, the same thing happens on the default language as well. So I’m not sure it’s related to TranslatePress. If you disable TP does it work again? You could try a compatibility test and see what’s causing those pins being misalligned.

    Thread Starter rwonnink

    (@rwonnink)

    Hi,

    I deleted cache and now it seems to act normally. Can you only check my website and the translation plugin on mobile? I can’t choose a language because the dropdown on mobile doesn’t work. If I try to click on the arrow it directly goes to the default language instead of folding open and give me the language options.

    Robert

    Thread Starter rwonnink

    (@rwonnink)

    Any news?

    Plugin Author Cristian Antohe

    (@sareiodata)

    Hi, is that the shortcode? Can you try to add the language in the menu directly? Perhaps that works better with your setup.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Broken site’ is closed to new replies.